3

I run rtorrent remotely on a seedbox. When I log in with a web interface I'm able to start torrents, and when torrent files get dropped into my watched folder that works too. However, when I try to start them by SSHing in to my seedbox and -r resuming the screen session that contains my instance of rtorrent, I can't seem to use the Ctrl+S keyboard shortcut to start torrents. I can stop and delete them with the Ctrl+D shortcut, and as far as I can tell all the other keyboard shortcuts work.

I've tried this from the Terminal app in OSX and from Cygwin on Windows.

Thanks for your insight!

  • I should add that in both of these cases, if I run rTorrent locally I don't have this issue. Only when running it remotely via SSH and screen. I'm not sure whether the issue is with screen or ssh, or something else. – Raygan Kelly Jul 15 '14 at 6:15
  • Have you tried using PuTTY on windows ? – Lawrence Jul 15 '14 at 8:21
  • I have not and won't be back at my Windows machine until some time tomorrow to try it. That said, I think it's something on the remote end, not on my end. I've tried one more terminal application in the mean time: iSSH on an iPad. Same issue. – Raygan Kelly Jul 15 '14 at 14:49
  • 1
    What exactly happens when you press C-S? My fist thought is that C-S sends XOFF to your terminal. – Arkadiusz Drabczyk Jul 15 '14 at 15:34
  • It seems as if nothing at all happens when I press Ctrl-s. Other keyboard shortcuts work, just not this one. – Raygan Kelly Jul 15 '14 at 23:43
3

I eventually found the answer for myself on this page.

The machine I was running rtorrent on had Ctrl+S and Ctrl+Q mapped to stop and start screen output. Unmapping these got things working again.

  • screen's flow toggle C-a C-f might help with these shortcuts. In -flow mode they may be passed on to the program. – frostschutz Jul 18 '14 at 18:20
1

If you wanted to keep the use of those keyboard commands outside rtorrent, here's an alias to only unset them when you run rtorrent:

alias rtorrent='stty stop undef ; stty start undef ; rtorrent'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.