8

I would like to use HDMI on my graphic card for audio output. ALSA shows it as a card with 4 devices and I can get sound through one of them (the other three are different channels, perhaps? I have only stereo output connected). Although Pulseaudio has the right card set as default, it seems to me that it plays on the wrong device. Pacmd shows that the sink has parameter alsa.device set to the first device listed by ALSA, but I can get sound only from the second one.

How can I force Pulseaudio to use another device of the same card as the default output?

or

How can I force ALSA to switch numbers of the first and the second device on the card?

4

It seems like I found a solution, at least for this particular case. Since I knew the card and device number assigned by ALSA, I just had to open /etc/pulse/default.pa. in editor and change this line

#load-module module-alsa-sink

into this

load-module module-alsa-sink device=hw:2,7

where 2 and 7 are my particular instances of card and device numbers. This created a new sink connected to the correct device, which was then used as the default output.

0

We can also use simultaneous outputs, this is easier to setup and powerful.

Install paprefs and pavucontrol.

sudo apt install paprefs pavucontrol

Then reboot (restarting pulseaudio alone won't works fine).

Into the sound preferences output tab, choose "Simultaneous output(..)"

Now open the pulse audio volume control (pavucontrol) utility, it will let to choose to mute some outputs, adjust gains independently, latencies offsets, and more.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.