2

Since the last few days I get an error message when I try to shut my laptop down:

System policy prevents stopping the system when other users are logged in

This error message includes a prompt for administrator password.

I don't think that there should be other users logged in.

How can I find out what the problem is?

What I've tried

$ w
 08:00:47 up  1:50,  2 users,  load average: 0,74, 0,95, 0,70
USER     TTY      FROM             LOGIN@   IDLE   JCPU   PCPU WHAT
moose    tty8     :0               07:57    1:49m  4.88s  0.11s x-session-manager
moose    pts/0    :0.0             08:00    2.00s  0.11s  0.00s w


$ loginctl
   SESSION        UID USER             SEAT            
        c1        117 couchdb                          
        c2       1000 moose            seat0           

2 sessions listed.

I'm not sure: is that already the problem?

$ sudo shutdown -h now worked as expected.

How I shut the computer down

By clicking on System > Shut Down... > Shut Down:

enter image description here

System information

I have Linux Mint MATE:

$ uname -a
Linux pc08 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
$ cat /etc/issue
Linux Mint 16 Petra \n \l
  • If it's any comfort I had a similar issue with Fedora about an year ago, probably bug #890827. I'm not sure if the same applies to Linux Mint, but what's the output of loginctl? – Cristian Ciupitu Jul 14 '14 at 22:17
  • @CristianCiupitu: It seems as if CouchDB might cause this problem. That would make sense, because I've installed CouchDB just some days ago. Do you have an idea how to fix it? – Martin Thoma Jul 14 '14 at 22:27
  • How is the CouchDB server run? – Cristian Ciupitu Jul 14 '14 at 22:35
  • @CristianCiupitu: I don't know. How do I find it out? (I've just installed the debian package) – Martin Thoma Jul 14 '14 at 22:46
  • Then it should be a system service and not cause any trouble at all. Are you sure CouchDB is to blame? – Cristian Ciupitu Jul 14 '14 at 22:50
0

By searching out I could find this:

Go to

/usr/share/polkit-1/actions/org.freedesktop.consolekit.policy

Then you should find out the code that has inside the message tag your message

<action id="org.freedesktop.consolekit.system.stop-multiple-users">
  <description>Stop the system when multiple users are logged in</description>
  <message>System policy prevents stopping the system when other users are logged in</message>
<defaults>
  <allow_inactive>no</allow_inactive>
  <allow_active>auth_admin_keep</allow_active>
</defaults>

Then change the

<allow_active> auth_admin_keep </allow_active>

to

<allow_active>yes</allow_active>

then save and restart. If you have the same problem with restarting your system, then is the same step but over the restart code.

<action id="org.freedesktop.consolekit.system.restart">
| improve this answer | |
  • I've used this system for many months and did not have this problem. Do you have any idea what could have changed that? How did you find this solution? – Martin Thoma Jul 14 '14 at 15:19
  • I google it and find it on a blog attecnica.wordpress.com/2013/04/27/… But it only say how to solve it not how it happens – tachomi Jul 14 '14 at 15:23
  • This helped you? – tachomi Jul 14 '14 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.