2

Here's the problem:

Manjaro Xfce/3.15.4, Alsa (No Pulse), Firefox 30 and 31, Gmusicbrowser, mplayer/smplayer

  1. Firefox with youtube html5 player - no problems
  2. Firefox with youtube html5 player and a basic .asoundrc - no audio
  3. Firefox with standard flash player no problems
  4. All other applications work with .asoundrc

I've tried various settings in .asoundrc, this is the current version.

pcm.!default {
type hw
card 0
device 0
}

ctl.!default {
type hw           
card 0
device 0
}

The reason I'm using the .asoundrc is to stop alsa resampling my 96000 tracks to 48000 and it works correctly.

card 0: SB [HDA ATI SB], device 0: ALC889 Analog [ALC889 Analog]
Subdevices: 1/1     Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC889 Digital [ALC889 Digital]
Subdevices: 1/1     Subdevice #0: subdevice #0

Any ideas?

Edit: I should mention, it's not just youtube. I have no sound with firefox/html5/.asoundrc anywhere.

  • Have you ever found a solution? I am also running without any PulseAudio and get no sound with HTML5 videos – Deim0s Jan 18 '15 at 13:54
2

Your .asoundrc disables all software mixing.

If you want to output everything at 96 kHz, replace it with something like this:

defaults.pcm.dmix.rate 96000
  • 1
    .asoundrc disabling the software mixing is a very good information. I removed the ~/.asoundrc and did set the preferences (my problem was that the default sound card was not the correct one) in /usr/share/alsa/alsa.conf and now the sound works like a charm in firefox. Many many thanks for the answer. – 7heo.tk Nov 14 '14 at 12:24
1

I just tried this and it works for me (where my card is card 0):

defaults.pcm.card 0
defaults.ctl.card 0
defaults.ctl.card 0

just add that to the top of your .asoundrc and restart firefox. The rest of the file does not actually need to be empty.

  • You save my night! Youtube+HTML5 work fine now with Firefox but soundcloud not. With Chrome soundcloud work with HTML5 :D – m4tm4t Nov 8 '15 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.