22

My ibus input method was broken after an update. So I switched to fcitx.

Actually, there are a handful IMs (Input Methods) installed in my Fedora 19 system, e.g. fcitx, ibus, yong, etc.

However, I don't know how to configure them. My default IM for gnome-terminal is yong, ibus for gmrun. As for firefox or chrome, I guess they use ibus by default, because GTK_IM_MODULE=ibus.

There are just-work solutions. I can switch IM by right-click-menu in some applications like gnome-terminal or gmrun. I can also specify IM with GTK_IM_MODULE. But how to do it automatically?

I know the IM settings have something to do with configuration files like

  • ~/.xinputrc
  • /etc/X11/xinit/xinputrc
  • /etc/X11/xinit/xinput.d/ibus.conf
  • /etc/X11/xinit/xinput.d/fcitx.conf
  • /etc/X11/xinit/xinitrc
  • /etc/alternatives/xinputrc

The questions are

  • How to configure IM properly?
  • What configuration files really matter? In which execution order?
  • 1
    Do you mean selecting an IME to use by an application or configuring a particular IME? – L29Ah Aug 13 '17 at 23:34
0

I have my X input method selected via env vars

$ set | grep fci
GTK_IM_MODULE=fcitx
IM_CONFIG_PREFERRED_RULE=zh_CN,fcitx:zh_TW,fcitx:zh_HK,fcitx:zh_SG,fcitx:ja_JP,fcitx:ko_KR,fcitx:vi_VN,fcitx
QT_IM_MODULE=fcitx
XIM=fcitx
XIM_PROGRAM=fcitx
XMODIFIERS=@im=fcitx

And although I use KDE Plasma desktop I have fcitx-config-gtk3 installed to configure my desired languages and other options

0

I recommend you use the fcitx-configtool to open the fcitx config window and then you can change Extra key for trigger input method to whatever you want.

Then you can cd into the fcitx config folder: cd ~/.config/fcitx and use chmod 444 profile to change the permission of the profile to read only, so that no one can change back to default value.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.