6

I've just performed a new install of arch linux (3.15.3-1) on a macbook pro 8.2

All of my data is on an exfat drive, and I've installed exfat-utils. However, when I try

mount -t exfat /dev/sdb1 ~/drivemount

the return is

mount: unknown filesystem type 'exfat'

I saw a post on the arch forum mentioning doing modprobe exfat-fs, which I proceeded to try to no avail. I've looked around here, but couldn't find a post that explained it, so here I am.

Do I need some other packages, like fuse-exfat? (And why doesn't it just work with exfat-utils?)

How might I resolve this?

14

I also installed just exfat-utils and fuse-exfat from the community repository but not `exfat-git'. After that mounting of an exfat usbstick worked just fine. Archlinux (3.18.5-3).

1

I struggled with this as well, but resolved it by installing the exfat-git package from the AUR. After that everything simply worked. No modprobe, no reboot, etc.

0

You only need a kernel module for exfat to just mount, not neccesarily the tools (checking the filesystem etc).

So just install fuse-exfat from the community repo and your done without reboot or manual modprobe or a non-fuse exfat implementation from the AUR (exfat-git or exfat-dkms-git), if you know what you're doing and that it's stable enough for your use case.

Archlinux x64 from 18 Feb 2015, everything up to date with pacman / yaourt. But generally this will stay true for the future, only some package names will change a little or new modules that implement exfat will become available.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.