2
benben@debian:~/goagent$ sudo apt-get install sqlite3
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
sqlite3 : Depends: libsqlite3-0 (= 3.7.13-1+deb7u1) but 3.7.17-1~bpo70+1 is to be installed
E: Unable to correct problems, you have held broken packages.

How may I use sqlite3?


benben@debian:~$ sudo dpkg -l | grep bpo | grep libsqlite
ri  libsqlite3-0:amd64                    3.7.17-1~bpo70+1                   amd64        SQLite 3 shared library

Here is the output of dependencies. It seems a lot of common packages depend on it.

I'm not sure about this, but I think maybe once I tried to install some package in unstable, which updated the libsqlite3-0 package automatically.

How may I rescue?

benben@debian:~$ apt-cache --installed rdepends libsqlite3-0
libsqlite3-0
Reverse Depends:
  libnss3
  iceweasel
  libyelp0
  libwebkitgtk-3.0-0
  libtracker-sparql-0.14-0
  telepathy-salut
  telepathy-logger
  libtelepathy-logger2
  telepathy-gabble
  libseed-gtk3-0
  python3.2
  python2.7
  python2.6
  packagekit
  libpackagekit-glib2-14
  libnss3
  libsoup-gnome2.4-1
  libgpod4
  libchamplain-0.12-0
  iceweasel
  gnome-settings-daemon
  gnome-packagekit
  glchess
  libedataserverui-3.0-1
  libedata-book-1.2-13
  libebook-1.2-13
  libebackend-1.2-2
  libcamel-1.2-33
  evolution-data-server
  colord
  aptitude
  libaprutil1-dbd-sqlite3
  • Please elaborate on what you're trying to achieve. You mentioned "downgrading" in the subject, but then you just posted apt-get install output. Posting dpkg -l | grep sqlite output may be useful. – Kempniu Jul 10 '14 at 9:59
  • Can we see the output of dpkg -l | grep bpo as well? You have the backports repo enabled, and your libsqlite3-0 has been installed from there. – Flup Jul 10 '14 at 10:25
  • Sorry for the confusion. libsqlite3-0(3.7.17-1) is currently installed, which cause the failure to install sqlite3. So I want to downgrade it. – wlnirvana Jul 10 '14 at 10:28
3

Judging from your dpkg -l output, it looks like libsqlite3-0-3.7.17-1~bpo70+1 has been selected for removal (r), but is still installed (i) for some reason. You can check if any of your installed packages depend on this package by running:

apt-cache --installed rdepends libsqlite3-0

If none of your installed packages depend on the problematic package, just purge it using:

apt-get purge libsqlite3-0

and then try installing sqlite3 again.

Also, the libsqlite3-0 package is not currently available from wheezy-backports, so if the above doesn't work, it might be a good idea to do an apt-get update and retry installing sqlite3 afterwards.

  • See update above. – wlnirvana Jul 11 '14 at 5:33
  • @wlnirvana Could you post the output of apt-cache showpkg libsqlite3-0 as well? That way we'll be able to see which packages depend on the problematic version of libsqlite3-0 and which have an "at least version X.Y.Z"-type dependency. – Kempniu Jul 12 '14 at 11:37
  • I reinstalled the entire system yesterday because I first dist-upgraded to Jessie to solve the problem, and then found my laptop was too old and slow to run Jessie, so I reinstall back to Wheezy.To be brief, I can't reproduce the problem now. But thanks though. – wlnirvana Jul 13 '14 at 7:59
  • I'm having the same problem. My system has hundreds of packages depending on libsqlite3-0, so many that I would guess I couldn't even boot if I purged as you suggested. – Buttons840 Aug 10 '14 at 19:25
  • @Buttons840 My suggestion was conditional; it's clear it doesn't make sense in your case. – Kempniu Aug 10 '14 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.