1

I have a focusrite scarlett 8i6 soundcard and I would like to make many sounds with it. Currently it's deadly silent and I want to crack on with some programming whilst listening to music!

I usually go for a very standard Ubuntu install, but thought I would give Linux Mint a try, but the soundcard doesn't seem to work currently.

After some fiddling with Linux Mint I've actually made it recognise the soundcard.

cat /proc/asound/cards:

 1 [USB            ]: USB-Audio - Scarlett 8i6 USB
                  Focusrite Scarlett 8i6 USB at usb-0000:00:14.0-1, high speed

I've blacklisted the onboard soundcard, but now I'm not sure how to use this one. It isn't picked up in sound preferences, by default that just has a dummy output now.

I've got pulseaudio, alsa and jack installed, but have no idea how to actually get any or all of those working together.

Some other info:

# /sbin/lsmod | grep snd
snd_usb_audio         149200  0   
snd_usbmidi_lib        25070  1 snd_usb_audio
snd_hwdep              13602  1 snd_usb_audio
snd_seq_midi           13324  0 
snd_seq_midi_event     14899  1 snd_seq_midi
snd_rawmidi            30095  2 snd_usbmidi_lib,snd_seq_midi
snd_seq                61560  2 snd_seq_midi_event,snd_seq_midi
snd_pcm               102033  1 snd_usb_audio
snd_seq_device         14497  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_page_alloc         18710  1 snd_pcm
snd_timer              29433  2 snd_pcm,snd_seq
snd                    69141  9                    
snd_usb_audio,snd_hwdep,snd_timer,snd_pcm,snd_seq,sn
d_rawmidi,snd_usbmidi_lib,snd_seq_device,snd_seq_midi
soundcore              12680  1 snd

I've also updated /etc/modprobe.d/alsa-base.conf:

options snd-usb-audio index=0

aplay --list-devices:

 **** List of PLAYBACK Hardware Devices ****
 card 1: USB [Scarlett 8i6 USB], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I don't really know much about pulseaudio, other than the basic of what it does.

But the soundcard doesn't seem to be picked up by it.

pacmd list-cards
Welcome to PulseAudio! Use "help" for usage information.
>>> 0 card(s) available.

For completeness the output of speaker test

speaker-test 1.0.27.1

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 192 to 2097152
Period size range from 64 to 699051
Using max buffer size 2097152
Periods = 4
was set period_size = 524288
was set buffer_size = 2097152
0 - Front Left
Time per period = 12.425529

But still no sound.

Any suggestions?

*******UPDATE***********

Command: amixer -c 0 contents

numid=1,iface=MIXER,name='Scarlett 8i6 USB-Sync'
  ; type=ENUMERATED,access=rw------,values=1,items=2
  ; Item #0 'Internal'
  ; Item #1 'S/PDIF'
  : values=0
  • 1
    Try running speaker-test. It's possible that PulseAudio does not find a stereo configuration. – CL. Jul 9 '14 at 19:45
  • I tried that already, before I black listed the built in card it made the sound through the on board speakers after blacklist it does nothing. – Purple Hexagon Jul 9 '14 at 19:47
  • 1
    Doesn't this device have six output channels? Run speaker-test with -c 6. What is the output of amixer -c 1 contents? – CL. Jul 10 '14 at 7:22
  • 1
    No mixer controls at all? What is the output of lsusb -v for this device? – CL. Jul 10 '14 at 19:08
  • 1
    All those bmaControls values are zero. Apparently, this device needs vendor-specific magic to be able to access the mixer controls. – CL. Jul 10 '14 at 20:23
-1

Replace options snd-usb-audio index=0 with options snd_usb_audio index=0

Here is how I got my scarlet to work on Debian Jessie:

  1. blacklist snd_hda_intel in /etc/modprobe.d/alsa-base-blacklist.conf

  2. remove pulseaudio

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.