After hearing the news that CentOS 7 had been published, I decided to install it on my computer. I downloaded the ISO image from the CentOS official website (the one named CentOS-7.0-1406-x86_64-DVD.iso) and then burned it onto a USB drive by using a tool named UltraISO.

After that, I rebooted my computer and pressed F12 to choose my boot device. (My GIGABYTE motherboard uses F12 to choose a boot device.) I chose this: UEFI: hp v245o 1100, where hp v245o 1100 is the USB name, and I suppose this is a so-called EFI boot from USB. After that, three menu selections are presented:

  1. Install CentOS 7,
  2. Test this media & install CentOS 7,
  3. and Troubleshooting -->.

At first I decided to choose option 1 to let it display all its running messages, so I typed e and here is what I get:

set params 'Install CentOS 7'
linuxefi /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=CentOS\x207\x20x86_64 quiet
initrdefi /images/pxeboot/initrd.img

So I removed the quiet param and pressed CTRLx to start, then I got this:

    fb error

I have no idea what the fb is, and the installation process just stopped there.

So I decided to try the 3rd option (the Troubleshooting --> one) with no luck; I still cannot install this CentOS 7 and I got something like:

> [7.471771] scsi 0:0:0:0: alua: not attached
> [7.474665] sd 0:0:0:0: [sda] no Caching mode page found
> [7.474682] sd 0:0:0:0: [sda] Assuming drive cache: write through
> dracut-initqueue[685]: Warning: Could not boot
> dracut-initqueue[685]: Warning: /dev/root does not exist

How I can solve this problem?

  • 1
    "fb" is the framebuffer -- but I do not think that is your problem. I'd guess it's UEFI, although it should be supported.
    – goldilocks
    Commented Jul 9, 2014 at 11:33
  • ...but it's not clear whether you need to do anything special to make it work.
    – goldilocks
    Commented Jul 9, 2014 at 11:39
  • So you mean I can do nothing but wait for CentOS team to fix this problem?
    – Xiangyu
    Commented Jul 9, 2014 at 12:15
  • I don't know -- I don't have an answer for you, I was just clarifying what the "fb" issue is about and that it is probably not the problem. People on #centos IRC say that it should support UEFI without any special effort, so that may be a wrong guess.
    – goldilocks
    Commented Jul 9, 2014 at 12:30
  • @Christopher - the edit you've made 2 times is breaking the display of the image that the OP included. Please stop doing that edit, it's not correct.
    – slm
    Commented Jul 9, 2014 at 14:46

8 Answers 8


I think you must make bootable usb using dd command (if your iso is in home directory):

First unmount (not eject) the usb: sudo umount /dev/sdb1

Then, write the image to the disk:

sudo dd bs=4M if=CentOS-7.0-1406-x86_64-Everything.iso of=/dev/sdb

Then it will not show /dev/root does not exist.

  • This fixed the problem for me. Switched from unetbootin to dd (provided by cygwin on windows).
    – Nick
    Commented Jul 15, 2014 at 13:38
  • 1
    This worked like a charm. Switched from Rufus here.
    – xiankai
    Commented Sep 8, 2014 at 4:40
  • I think that sudo umount /dev/sdb . Please explain for me!
    – Vy Do
    Commented Nov 26, 2014 at 10:42
  • Just in case you have plugged in your USB drive and you have no idea where it is mounted, but you can open the drive and browse the contents. do the following: 1) In the USB's folder, press Ctrl+L to see the path where the contents are. Example might be: /run/media/george/the-disk 2) cat /proc/mounts and look where the above folder in (1) is mounted. The location will precede the path from (1). Example: /dev/sdc1. 3) From there, follow this answer.
    – Shailen
    Commented Feb 1, 2015 at 14:23
  • However, note that this method did not work for me on VMware11. Plugging back the USB on Windows asked me to format my USB. When booting into my USB, the system hung up on a blinking cursor.
    – Shailen
    Commented Feb 1, 2015 at 15:24

/dev/root is missing.

This can often be caused by a mismatched label or /dev/sdXx root device when booting from USB.

When the dracut shell becomes available, create a directory:

mkdir /mnt/

Mount different block devices until you have found the one that contains the USB installer(this typically doesn't happen on true/Virt CDROM mounts).

Once you find the /dev/ for the USB (for instance, if your system reads it as HDD, it might be /dev/sdd1), perform the command blkid on the device:

blkid /dev/sdd1

This should tell you the UUID of the block device, you will want to write this down.

Once written down somewhere you can use it, reboot the system. When the grub installer boot options menu loads, press "e" to edit the grub kernel parameters.

From here, move to the end of the line, remove quiet so you have an idea why the install fails. Then change the part like:

some boot parameters maybe efi, maybe bios : LABEL=THELABELYOU\X04HAD


some boot parameters maybe efi, maybe bios : UUID="THEUUID-YOUWROTEDOWN"

Then press ctrl+x to boot with those parameters, hopefully it should work.

  • I've been search and searching for an answer for hours and this did it for me. The -volid wasn't correct in the ISO I created. That is, it was different than the isolinux.cfg file. THANK YOU.
    – e40
    Commented Sep 30, 2015 at 5:51

I have not installed CentOS 7 myself yet, but you can try

linuxefi /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=CentOS\x207\x20x86_64 quiet nomodeset

i.e: append 'nomodeset'

If that works, I would blacklist Nouveau after install.

  • Hi, after adding this "nomodeset", I can get through the fb process, but then I got a warning which said that /dev/root does not exist. Any suggestion about this?
    – Xiangyu
    Commented Jul 9, 2014 at 16:33
  • 2
    Is this happening while booting from the USB device? Found this article that seems to explain what is happening. The article has since been removed but here it is in a web archive: dont-use-universal-usb-stick-writers If booting from a DVD/CDROM is not an option perhaps you need to look into disabling UEFI.
    – user74509
    Commented Jul 10, 2014 at 8:54
  • The installer failed to find the iso root, this is not about the video settings.
    – daisy
    Commented Jun 20, 2016 at 8:20

add hd:/dev/sdb1 <- to your U disk device name.

  • One-line answers are often not the most helpful. If you believe in this solution's relevance, consider expanding your answer to include an explanation or documentation explaining or supporting your solution.
    – HalosGhost
    Commented Aug 7, 2014 at 4:25

Unetbootin has never failed me, you can use it to create a bootable USB drive you can install from.

  • 9
    It failed me countless times. Commented Dec 12, 2014 at 20:34

I had the same issue with a virtual CD. The installer looks up the drive based on the label that contains spaces (\x20). In my case, the installer could not find the virtual CD. I changed the command line (press TAB) to DRIVE=hd:/dev/sr0


I experienced this issue when netbooting the install over PXE. I solved the problem by removing ksdevice=eth0 parameter from kernel command line. This setting worked with RHEL6, but caused newer versions to fail.


I had problems with several USB image writers, but Win32 Disk Imager worked for me.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .