5

When I edit files with vim there is always this in the cmd line area,under the status line,all buffers' names(image : http://ompldr.org/vOHZtdg)

Is there any way I can remove it?

4
  • Are you using some plugin for buffer management? By the way, you could also show us your vim settings.
    – nozimica
    Jun 1, 2011 at 21:52
  • What does :set statusline show as the current format string for your status bar?
    – Caleb
    Jun 2, 2011 at 7:21
  • This is the statusline in my .vimrc: set statusline=\ \%F%m%r%h%w\ ::\ %y\ [#\%n]\%=\ [%p%%:\ %v\::\%l/%L]\
    – bollovan
    Jun 2, 2011 at 12:01
  • @nozimica I'm using MiniBufExplorer if that helps.
    – bollovan
    Jun 6, 2011 at 13:47

2 Answers 2

1

Your vim config file has some extra custom stuff somewhere because that's not part of the default package.

Try adding this to your ~/.vimrc file:

:set laststatus=0

You can test by just running that in an open editor.

Edit: Based on your reported status line, you should probably change:

set statusline=\ \%F%m%r%h%w\ ::\ %y\ [#\%n]\%=\ [%p%%:\ %v\::\%l/%L]\ –

…to:

set statusline=\ \%F%m%r%h%w\ ::\ %y\ [#\%n]

…but you may need to experiment to see which parts you want to keep and which parts are the line you don't want.

3
  • By setting laststatus=0 the statusbar dissapears,I want to hide only that text that appears under the statusline.
    – bollovan
    Jun 2, 2011 at 11:59
  • See my edit, it look like your status line preference just has more stuff than you want to see. You can par it down yourself.
    – Caleb
    Jun 2, 2011 at 12:12
  • Hmm,that doesn't work.Also the last part in the statusline is for percent , colon , current line / all lines.
    – bollovan
    Jun 2, 2011 at 12:34
1

It looks like buftabs.vim which modifies the 'statusline' as you switch buffers, then restores 'stl'.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.