1

This seems like the Holy Grail:

I have installed rEFInd 0.8.3 on my macmini3.1 (late 2009) and have verified that it works correctly: it intercepts the boot process and displays an icon for OSX, and then proceeds to let OSX boot. It's my intention to have a dual-boot OSX/Linux Mint, once I can get Linux installed on the HD.

I have downloaded linuxmint-17-cinnamon-64bit-v2.iso and confirmed that it boots under VirtualBox 4.3.12 on my MacBookPro 10.1 (Retina, 15-inch, Early 2013).

Now, I want to create a bootable USB flash drive that will boot Linux Mint on the Mac Mini. Here's where I've tried all sorts of recipes I've collected from Google, with very little success.

This link to an article, written 6/13/2013, described how to

  • format one's USB flash drive as FAT32, 1-partition, MBR
  • use a free utility called Mac Linux USB Loader v2.0 to perform the remaining work of putting my Linux Mint image onto the flash drive.

And I was actually able to reboot my MBP, holding down option, and select and boot into Mint!

However, my Mac Mini does not even recognize the flash drive as being a boot volume. Could this have anything to do with the presence of rEFInd on that machine?

The recipes I've tried have been all over the map. Some use GUID Partitions rather than MBR. Some want you to convert the .iso to .dmg. Some are directions for creating a bootable drive, where "bootable" includes the caveat "but not on your Mac". I have no idea what direction to go in (apart from the store, to get a cheap PC, which I'm not quite ready to do yet).

Any suggestions or follow-ups would be most welcome.

0

I'm pretty sure the following will work:

sudo dd if=path/to/image.iso of=/dev/diskx bs=4M

Breakdown:

  • sudo to run the command as root (bad things happen when someone does this to disk0)
  • dd copies data from a file to a block device (or vice versa)
  • if=path/to/image.iso tells dd where to get data from
  • of=/dev/diskx tells it where to put the data. Replace diskx with the device name! (probably disk1 on BSD-like OS's (like OS X) or sdb on Linux)
  • bs=4M makes the transfer faster. IIRC it uses more RAM, but that's only ever affected me on Chrome OS (in the shell, froze up the whole Chromebook, whoops!)
  • I'm going to need more details. First, OSX wants 'bs=4m', not 'bs=4M'. Next, we need to mention unmounting the drive if it's already mounted. 'diskutil list' will help locate it. Mine says /dev/disk1 #: 0: FDisk_partition_scheme *16.0 GB disk1 1: DOS_FAT_32 BOOTILDA 16.0 GB disk1s1 Do I unmount disk1 or disk1s1? I'll assume disk1 and then try your command. – Chap Jul 22 '14 at 1:56
  • Make that "I'll assume disk1s1...". – Chap Jul 22 '14 at 4:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.