1

I have a pretty old Ubuntu 8.04 machine. The machine doesn't have a DVD reader/writer in it.

Challenge: Now, the challenge I am facing is to install RHEL6 in this machine.

Obstacle 1: I needed to make a boot image from USB disk so that I can use it to install the RHEL6 in this machine.

I was able to overcome the obstacle 1 successfully by following the below approach.

I used the iso2usb software and used an existing image of RHEL6 to have a bootable USB disk for installation. It worked perfectly fine in another machine when I tried booting from USB and installing.

Obstacle 2: Now, when I use this same USB in the server machine, it gives me the first screen where I can select to install the RHEL6. After selecting to install the RHEL6, it gives me an error as,

Unable to find any devices of the type needed for this installation type. Would you like to manually select your driver or use a driver disk?

I am stumped at this obstacle and tried various options to overcome this.

I tried using an USB drive with lesser storage (4 GB) since I guessed using larger USB storage (earlier I used 16 GB ) sometimes might not work well with the ancient hardware.

I also tried the option specified here. When the bootloader screen appears, I added,

linux all-generic-ide irqpoll pci=nommconf

I also tried using various USB ports. The USB is getting recognized but again gives the same error as above.

Now the only option left to try is to hook up a DVD drive to this machine and try the installation. However, I just want to know if am missing out any other option. Also, is it possible that the installation is failing because of the hardware in the machine? I am not sure if the driver update for the USB drives might fix the problem.

  • 1
    Sounds like the necessary USB drivers are not available for this HW. If you can find a USB thumbdrive that works on this system you can do a remote install like so: techotopia.com/index.php/… – slm Jul 8 '14 at 22:49
  • @slm, thanks. If I do network installation, I am not sure if the network drivers are available to carry on the RHEL6 installation. I mean, the error is because, for RHEL6 to be installed we need some newer drivers right? I doubt if the newer drivers for Network cards are available in that older Ubuntu machine. – Ramesh Jul 8 '14 at 23:49
  • If you use a network image of RHEL/CentOS you can typically put that onto a USB drive and then boot using it. They typically have vanilla drivers which I've had good success with in the past. – slm Jul 8 '14 at 23:58
  • 1
    You can also always pull the HDD out of the system and do the install on another system, and then put the HDD back into the problem system. – slm Jul 9 '14 at 1:33
  • @slm, I wish I thought of it yesterday itself. Anyways, I learnt how to do the installation from USB stick and what all possible issues I could run into if I try from USB stick. :) – Ramesh Jul 9 '14 at 1:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.