I have 64 bit OpenSuse 11.4 and has boost 1.44. I'm trying to update boost to version 1.46 through 1-Click install of OpenSuse's site.

However I'm getting a lot of errors about it's repositories being invalid. So I tried the manual package by downloading its rpm, however, installing it requires so many dependencies that I need to download as well.

I also tried zypper, here's my repo list:

# | Alias                               | Name                                | Enabled     | Refresh | URI                                                                                                
1 | Updates-for-openSUSE-11.4-11.4-0    | Updates for openSUSE 11.4 11.4-0    | Yes      | Yes     | http://download.opensuse.org/update/11.4/                                                          
2 | devel:gcc:gcc46                     | devel:gcc:gcc46                     | Yes     | Yes     | http://download.opensuse.org/repositories/devel:/gcc/openSUSE_11.4/                                
3 | devel:libraries:c_c++               | devel:libraries:c_c++               | Yes     | Yes     |  http://download.opensuse.org/repositories/devel:/libraries:/c_c++/devel_gcc_gcc46_openSUSE_ Factory/
4 | http-download.opensuse.org-5ae5abcf | http-download.opensuse.org-5ae5abcf | Yes     | Yes     | http://download.opensuse.org/repositories/devel:/gcc/openSUSE_11.4/                                
5 | repo-debug                          | openSUSE-11.4-Debug                 | No      | Yes     | http://download.opensuse.org/debug/distribution/11.4/repo/oss/                                     
6 | repo-debug-update                   | openSUSE-11.4-Update-Debug          | No      | Yes     | http://download.opensuse.org/debug/update/11.4/                                                    
7 | repo-non-oss                        | openSUSE-11.4-Non-Oss               | Yes     | Yes     | http://download.opensuse.org/distribution/11.4/repo/non-oss/                                       
8 | repo-oss                            | openSUSE-11.4-Oss                   | Yes     | Yes     | http://download.opensuse.org/distribution/11.4/repo/oss/                                           
9 | repo-source                         | openSUSE-11.4-Source                | No      | Yes     | http://download.opensuse.org/source/distribution/11.4/repo/oss/                                    

When I do zypper update, here's what I'm getting:

Loading repository data...
Reading installed packages...

The following package updates will NOT be installed:
aalib aspell aspell-en augeas-lenses binutils binutils-devel binutils-gold boost-devel   boost-devel-32bit boost-jam cpp45 curl db-utils elfutils expat gcc45 gcc45-32bit gcc45-c++  gcc45-info gd gdb gdbm gdbm-32bit gdbm-devel 
  giflib gmp-devel hunspell hunspell-tools ispell ispell-american libadns1 libaio  libaio-devel libasm1 libaugeas0 libblocxx6 libcloog0 libcurl4 libcurl4-32bit libdaemon0  libdb-4_5 libdb-4_5-devel libdb-4_8 libdb-4_8-32bit 
  libdnet1 libdw1 libelf0 libelf1 libexpat1 libexpat1-32bit libexpat-devel libffi45 libgcc45 libgcc45-32bit libgcj45 libgcj45-devel libgcj45-jar libgcj_bc45 libgcrypt11 libgfortran45 libgle3 libgmp10 libgmpxx4 libgomp45 
  libgomp45-32bit libical0 libidn libidn-32bit libieee1284 libilmbase6 libIlmImf6 libiodbc3 libloudmouth-1-0 libmp3 libmpc2 libmpfr4 libmtp8 libneon27 libppl9 libppl_c4 libpth20 libredland0 libslang2 libssh2-1 
  libssh2-1-32bit libssh4 libstdc++45 libstdc++45-32bit libstdc++45-devel libstdc++45-devel-32bit liburiparser1 libv4l libv4l1-0 libv4l2-0 libv4lconvert0 LibVNCServer libwmf libxslt pkg-config t1lib zziplib 

Nothing to do.

Isn't there an easier way to update all of boost and its dependencies?

  • Try using zypper? Also, can you post what errors you are getting, please? Jun 2, 2011 at 4:13
  • 1
    You need to figure out why zypper doesn't want to install your updates. Number 3 doesn't look like it belongs. It is part of OpenSUSE 11.4? Take that one out and try again. Tip 1: if you get an error message, trying Googling for it. You can often find useful information. Tip 2: Use @user at the beginning of a comment if you want user to be notified of that comment. And yes, zypper is as good as it gets. It is also helpful to post zypper lr -d. Jun 3, 2011 at 6:46

1 Answer 1


It looks like you're using the "one-click" installer for the factory distro, rather than 11.4.

Try this link: http://software.opensuse.org/main/ymp_without_arch_and_version?base=openSUSE%3A11.4&package=boost&project=devel%3Alibraries%3Ac_c%2B%2B&query=boost&repository=openSUSE_11.4 instead.

  • Tried it... I'm getting this message after the installation...
    – Owen
    Jun 14, 2011 at 6:59
  • Software installation Installation was only partially successful. The following packages could not be installed: boost
    – Owen
    Jun 14, 2011 at 6:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .