4

Problem

The Fn-F4 function key combination does not result in hibernating, instead it resets the internet connection instead

Symptoms

pm-hibernate and pm-suspend just reset the connection. hibernate works, as does s2both.

Setup

Lenovo X230, updated Debian testing, 3.14 kernel, i3 wm, lightdm, xfce4-power-manager.

On Lenovos, Fn-F4 is a special function key, which is supposed to hibernate the machine (moon symbol).

Since pm-hibernate is not working, the idea was to change the handler to s2both. I cannot find the script responsible for handling the key press though. Other system keys work as expected (volume, mute, etc).

Things I've tried:

  1. Catching XF86Sleep or XF86WakeUp in .i3/config (my window manager config file). This file is handling some of the other special buttons like XF86AudioRaiseVolume. Variations onbindsym XF86Sleep exec "hibernate". No effect.
  2. Switching out the backend for pm by adding SLEEP_MODULE=uswsusp in /etc/pm/config.d/module. No effect.
  3. Modyfying etc/acpi/sleep_suspend.sh to use hibernate or s2both. No effect.
  4. Poking around xfce4-power-manager setting GUI. Nothing here.

Questions

  • Can someone please explain who is handling the power options here? ACPI? xfce4-power-manager?

  • What is the relationship between these?

  • What happens when I press Fn-F4?

  • Who is handling the key press and how do I change / fix it?

  • What is the best practice for handling suspends / hibernates gracefully?

1

On my thinkpad I use xbindkey to do this.

Setup:

  1. Install xbindkeys apt-get install xbindkeys
  2. Edit your config ~/.xbindkeysrc.scm

    (xbindkey '("XF86Standby") "sudo pm-suspend")

  3. Run xbindkeys in i3/config

    exec --no-startup-id xbindkeys&

or in the .xinitrc

xbindkeys &

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.