1

I want to remove the ImageMagick,But I got this error

[root@localhost ~]# cat /etc/redhat-release 
CentOS release 6.4 (Final)

[root@localhost ~]# rpm -qa "ImageMagick*"
ImageMagick-devel-6.5.4.7-7.el6_5.x86_64
ImageMagick-6.5.4.7-7.el6_5.x86_64
ImageMagick-perl-6.5.4.7-7.el6_5.x86_64

[root@localhost ~]# yum --skip-broken remove ImageMagick
Loaded plugins: fastestmirror
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package ImageMagick.x86_64 0:6.5.4.7-7.el6_5 will be erased
--> Processing Dependency: libMagickCore.so.2()(64bit) for package: ImageMagick-perl-6.5.4.7-7.el6_5.x86_64
--> Processing Dependency: libMagickCore.so.2()(64bit) for package: ImageMagick-devel-6.5.4.7-7.el6_5.x86_64
--> Processing Dependency: libMagickWand.so.2()(64bit) for package: ImageMagick-perl-6.5.4.7-7.el6_5.x86_64
--> Processing Dependency: libMagickWand.so.2()(64bit) for package: ImageMagick-devel-6.5.4.7-7.el6_5.x86_64
--> Processing Dependency: ImageMagick = 6.5.4.7-7.el6_5 for package: ImageMagick-perl-6.5.4.7-7.el6_5.x86_64
--> Processing Dependency: ImageMagick = 6.5.4.7-7.el6_5 for package: ImageMagick-devel-6.5.4.7-7.el6_5.x86_64
--> Running transaction check
---> Package ImageMagick-devel.x86_64 0:6.5.4.7-7.el6_5 will be erased
---> Package ImageMagick-perl.x86_64 0:6.5.4.7-7.el6_5 will be erased
--> Finished Dependency Resolution
http://repos.fedorapeople.org/repos/peter/erlang/epel-6/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: epel-erlang. Please verify its path and try again
 You could try running: rpm -Va --nofiles --nodigest
1
  • try disabling repos in /etc/yum.repos.d/*.repo files
    – TPS
    Jul 7 '14 at 4:48
1

It looks like you need to fix your repos, I would do as Tejas suggested and disable the epel repo that is causing the problem.

But to work around the problem, first make sure you want to remove ImageMagick even though other packages lists it as a dependency (ImageMagick-perl-6.5.4.7-7.el6_5.x86_64 and ImageMagick-devel-6.5.4.7-7.el6_5.x86_64).

If you know that and still want to remove it you can use:

rpm -e --nodeps ImageMagick

But remember, only use --nodeps if you know what you are doing.

0

The repo seems to be called epel-erlang.

  • Disable third-party repos; yum-config-manager --disable epel-erlang
  • clean up unmaintained software/repos;

    yum remove `yumdb search from_repo epel-erlang |egrep -v '(from_repo|^$)'`
    
  • rpm -ev --nodeps ImageMagick and/or other conflicting packages;

  • then, yum check-update && yum upgrade should take care of dependencies.

By the way, I'm not sure that --skip-broken is intended for removing a specific package. Most often it's used to skip broken dependencies when installing or upgrading multiple packages and/or system upgrades.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.