2

In a LibreOffice Writer document, I want to disable autorecovery save but I want automatic save be enabled. Is there any way to do this?

Saving takes time for large documents. Saving both the document and autorecovery is more time-consuming. I want just save the document.

1

Looking at the options it doesn't look like you can disable the saving of the "AutoRecovery" option and still have it automatically save the document. It's accessible via the following menu.

Tools -> Options -> Load/Save -> General -> Save AutoRecovery Information every ... Minutes

   ss#1

NOTE: This will disable the saving of the "AutoRecovery" info, but you cannot have that disabled without also disabling the "auto saving" feature. You could set the timeout to something really large which would minimize its impact.

It should also be noted that even with this disabled, when you run libreoffice it will still attempt to recover even with the above option disabled. To truly stop libreoffice from attempting to make use of a "AutoRecovery" file, you'll need to make use of this switch, -norestore, when you launch Writer, Calc, Impress, etc. like so:

$ libreoffice -norestore --impress

References

  • So probably a macro or some other artificial auto-save command is possible?! – user69453 Jul 7 '14 at 0:15
  • @user69453 - potentially. – slm Jul 7 '14 at 0:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.