0

I have an Alfa Wifi dongle. This dongle should have a sensitivity of -100 dbi at 1 MBit speed.

  • Is it enough to set hw_mode to "a" to get highest range?
  • Are there other settings which have to get changed?

My config:

###############################
# Basic Config
###############################
interface=wlan0
driver=nl80211

###############################
# DRAFT-N
###############################
#ieee80211n=1
#ht_capab=[HT40-][SHORT-GI-20][SHORT-GI-40]
#wmm_enabled=1
channel=8

##########################
# Local configuration...
##########################
ssid=bar
hw_mode=b
#hw_mode=g
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=foo
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
  • What do you mean with 'highest range'? Many drivers have no sensitivity settings. Try iwconfig wlan0 sens. – user55518 Jul 6 '14 at 15:30
  • I mean the highest range I get with the lowest data transfer rate, in theory. The higher the data rate the less sensitive the sensor becomes. For my purposes I am fine to have even 1 MB/s. I just need range. – dgrat Jul 6 '14 at 20:15
  • I see, in other words it's the distance. I'd say this setting has become obsolete through frequency hopping and other features that are managed by hardware. Anyways, you need to tune other settings regarding the hardware capabilities. iw phy is a good starting point. – user55518 Jul 6 '14 at 20:24
  • I am not sure, whether frequency hopping or reducing the data rate will not cause lags for a short time when applied. I guess it is so and I don't want to have them. I just want a steady connection over a high distance. – dgrat Jul 7 '14 at 12:40
  • The algorithm checks continuously for the line quality and selects the best connection, but you still can clamp it to the lowest throughput. High sensitivity and low power sender results in high noise. What you can do is to increase txpower to (allowed) maximum, purchase good (directional) areal. link – user55518 Jul 7 '14 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.