5

I got the Arch Linux (march build) iso file through bittorrent lately.

I tried to run it in VM, but it only gets up to the main screen (The screen where you select what you want to do) shown below:

enter image description here

But when I select first option, it shows a black screen which goes nowhere. The Hardware Information option seems to work, but it's out of my intellectual capacity so I ignored it.

I then tried qemu with a simple qemu-system-x86_64 ./location to file command. It shows a slightly different image:

enter image description here

On selecting x64-86 I get errors:

enter image description here

I am a Ubuntu user, so I don't get anything of this, but the first error seems to be:

failed to access perctr msr(msr coo1ooo4 is 0)
6
  • 4
    I'm not sure about the perfctr message so I won't say anything about it but the message after that ("XZ-compressed data is corrupt) is worrysome. Did you verify your ISO file with any of the checksums at archlinux.org/download ? The easiest way to do that would be md5sum path-to-the-file or sha1sum path-....
    – Wieland
    Commented Jul 6, 2014 at 9:48
  • @Wieland I would surely do, but the problem is I have old ISO from march. How do I get sha1sum/md5sum for it? website only provides latest ISO's sha1sum/md5sum. If you have old ISO sha1sum/md5sum, please provide it. Commented Jul 6, 2014 at 13:23
  • archlinux.org/releng/releases/2014.03.01 has checksums for the old isos.
    – Wieland
    Commented Jul 6, 2014 at 14:06
  • 1
    @Wieland You were right. The ISO was tampered one. the checksums did not match. But how did I got wrong ISo even after getting it from official site's official Torrent? Should I use direct link instead? Commented Jul 7, 2014 at 14:27
  • I don't know how you got a corrupt ISO. Did you download a newer one and does it work?
    – Wieland
    Commented Jul 8, 2014 at 13:02

1 Answer 1

1

I get this message (failed to access perctr msr) on boot with a functioning Arch guest in Virtualbox. This issue has been discussed on the Arch forum (link below) and apparently is related to a cpu feature that does not exist on the system giving the error message, but the feature is unimportant, thus the message may be ignored.

https://bbs.archlinux.org/viewtopic.php?pid=1279852

In the last post:

2013-07-07 09:24:35

endle Member Registered: 2013-07-07 Posts: 1

Re: kernel error on QEMU VM boot: Failed to access perfctr msr mich41 wrote:

Probably something unrelated, maybe booting without "quiet" would reveal what exactly is happening before it hangs.

Thank you! After booting without 'quiet', I found where the problem is.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .