2

I have dabbled in running a Debian server before, but this is my first time using its graphical interface for my main pc. I have been trying to install the nvidia proprietary drivers. I have SLI gtx 460s 1GB. I am running Debian "Jessie" (if it turns out my issues are due to me running the testing build, please let me know).

So far, I have tried following the exact directions on the Debian wiki.

Upon reboot, my primary monitor remains completely blank once the desktop environment launches (I never even see the login screen), though it is still receiving some sort of video signal because the monitor doesn't complain about no signal. This contrasts my secondary monitor which is given no signal whatsoever. Oddly, when I hook up my monitor via HDMI to my motherboard's integrated graphics, I see a black screen with a cursor blinking at the top left corner. I am able to alt+ctrl+F1 to login to the terminal, purge my system of nvidia packages, delete the xorg config file, and reboot; this returns my system to a usable state using nouveau, dual monitors and everything.

I have tried slightly different methods such as installing the 'nvidia-driver' metapackage. Still, I get the same result.

Digging through the Xorg log, I found this segment:

[     7.605] (II) LoadModule: "glx"
[     7.605] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[     7.642] (II) Module glx: vendor="NVIDIA Corporation"
[     7.642]    compiled for 4.0.2, module version = 1.0.0
[     7.642]    Module class: X.Org Server Extension
[     7.642] (II) NVIDIA GLX Module  331.67  Fri Apr  4 11:43:47 PDT 2014
[     7.642] Loading extension GLX
[     7.642] (II) LoadModule: "nvidia"
[     7.642] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[     7.649] (II) Module nvidia: vendor="NVIDIA Corporation"
[     7.649]    compiled for 4.0.2, module version = 1.0.0
[     7.649]    Module class: X.Org Video Driver
[     7.650] (II) NVIDIA dlloader X Driver  331.67  Fri Apr  4 11:24:40 PDT 2014
[     7.650] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[     7.650] (++) using VT number 7

Any help would be greatly appreciated. I'll gladly provide any more information that's required. Thanks.

2

what you describe sounds very similar to a problem I frequently have when installing user PCs with nvidia cards and proprietary drivers (debian wheezy and jessie) - I'm usually able to solve it using the following procedure and the attached xorg.conf file (I remember trying the one from the Debian wiki site once, but something must have been wrong, or I would still use it).

On the Ctrl+Alt+F1 terminal:

/etc/init.d/lightdm stop
apt-get install nvidia-driver
apt-get clean
depmod -amodprobe -r nvidia
apt-get update
apt-get upgrade
modprobe nvidia

After those steps I copy the following xorg.conf from some USB stick or network location, and then restart lightdm:

/etc/init.d/lightdm start

The xorg.conf file:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
  • 2
    You don't need this entire xorg.conf file on a modern Xorg installation; just the "Device" section is sufficient to tell it which driver to use. It can autodetect the rest. – Wyzard Aug 6 '14 at 3:21
  • Thank you for the information! Somehow I had this in the back of my mind that it should be like this, but I never pursued the issue. The curse with working things.. – chris-sc Aug 6 '14 at 8:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.