2

I am running AT&T UNIX System V Release 4 Version 2.1 inside VirtualBox, and want to create a new "user account" for myself. At first, I simply created a new user with the useradd command, but didn't specify a group. When I logged in, I didn't even have a high enough permission level to create a new directory in my home folder. I then deleted my account and recreated it using the same command, except that I specified that the group is "adm". After doing this, I was able to create a new directory. This indicates to me that I now have a higher permission level.

Is this the correct way to add an administrator user? If so, what limitations are still in place?

  • If you have the command sudo usermod you can use that to modify a user. – slm Jul 4 '14 at 19:45
  • The sudo command isn't available on the system. – Strato1 Jul 4 '14 at 20:14
  • @Strato1 - what about the command usermod? – slm Jul 5 '14 at 0:18
  • @slm I have tried the usermod command, but am unsure how to use it to add administrative privileges. – Strato1 Jul 5 '14 at 4:40
  • @illuminÉ I know that this is not a problem involving installed packages. Also, my system cannot run the command you provided. On my system, it is used such as: pkgadd -d diskette1. It installs packages off of floppy disks. – Strato1 Jul 5 '14 at 4:43
1

I'm not familiar with ATT SVR4 — it was old before my time. But from your description, I think I can provide enough guidance to solve your problem.

Unix doesn't exactly have a notion of “administrator user”. That's a Windows name that doesn't map directly to a Unix concept. Under Unix, the only administrator account is root, user ID 0. Accounts that belong to physical users don't have such characteristics. An administrator is someone who knows the password to the root account. On systems that use sudo, such as Ubuntu, you can say that an administrator account is an account that is allowed to run programs as root through sudo, but sudo is not a historical Unix tool and is not bundled with SVR4. The traditional way to become root is with the su command, and that requires knowing the root password.

Accounts do belong to one or more groups, which can indirectly confer privileges, but that's more varied than having “administrator users”. I remember systems where the adm group gives the permission to read system log files (it's even the case in some recent Linux distributions); but that's only one thing among many. In some Unix variants (I don't know about SVR4), running su has an additional prerequisite, that the user must belong to the wheel group.

In any case, you don't need any special permission to create a subdirectory in your home directory. It's possible that the adduser command on SVR4 doesn't create the new user's home directory, or requires an option to do so; the syntax of useradd is not standardized, so check the man page on your system.

In summary:

  • To create an account, use useradd. If you need to create the user's home directory by hand, you can use these commands (as root of course):

    mkdir /home/bob
    chown bob /home/bob
    chgrp users /home/bob      # or whatever bob's primary group is        
    chmod 755 /home/bob
    
  • To create an administrator user, create a user, and give the person who'll be using the account the root password. If required, add the user to the wheel group (either with built-in tools, if provided on your Unix variant, or by editing the /etc/group file manually).

  • Thank you for the explanation. However, adding a user to the adm group does allow the user to use certain commands which weren't available before. Also, I was unable to create a directory in my own home directory before I specified the adm group. The wheel group does not exist on SVR4. I did not know about the su command, though. Thanks. – Strato1 Jul 5 '14 at 17:19
  • One quick question: What does chmod 755 /home/bob do? – Strato1 Jul 5 '14 at 17:22
  • @Strato1 Every user should be able to create a directory in their home directory. If you couldn't, it's probably because you were in the wrong directory or the home directory had wrong permission. If you need further help with that, copy-paste a transcript of the commands that you used, the messages produced by these commands, and the entries in /etc/passwd and /etc/group. The chmod command sets reasonable permissions (readable by everyone, writable only by the owner) to the newly created home directory. – Gilles Jul 6 '14 at 18:23
  • I think I realize what I did wrong. When I created the new user, I failed to specify the -m switch. Because of this, I had to create the new directory using the mkdir command. I must not have set the appropriate permissions. – Strato1 Jul 10 '14 at 18:41
0

On old unix when you create a user,you must tell to create home. So correct way is

useradd -g other -m -d /home/utente
passwd utente
chown utente /home/utente
chgrp utente /home/utente
chmod 755 /home/utente

of course replace utente with your name. If you want admin user,must use root as group ,but is dangerous,better use normal user and use

su -

for admin templates. And if you want you can create a script for automatic creation of user. How to do? Simply google for it ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.