6

When a process that has an open window is activated, it remains un-focused and hidden underneath other windows but gives a small notification below that there was action. This is particularly evident in these situations:

  • PCManFM File Manager - when it is already open to a folder and is given a new one to open into a new tab
  • File-Roller or Archive Manager - when it has a file open already and gets a new one and opens in a window.

I use Gnome 3.x primarily. I've scoured to the end and back of dconf 30 times and the closest I could find was focus_mode = click and auto_raise = true but neither had any effect.

I've been at this so long I'm bound to be overlooking something. Feel free to set me straight if you see something blatant I'm missing. Here's the system setup:

  • Ubuntu 14.04 x64 (and Fedora 20)
  • Gnome 3.x (all versions affected)
  • AMD Catalyst 13 drivers for Radeon R9
  • gdm

EDIT #1

nautilus is affected by this as well I just confirmed.

I really need these windows to show up when stuff happens. Especially because I'm the one making the stuff happen, not some random process.

Gladly will post any settings or config files as desired.

EDIT #2

I have narrowed the action responsible down to Alt+Tab (even when re-assigned to a new key mapping AND when another mapping with a similar action is re-assigned to it).

At first I thought it could be the Alternate Tab extension but disabling that did nothing.

To replicate: Open a files window, Alt+Tab to another window and then open another instance of the file manager. It doesn't have to be in a tab; it will occur with a new window as well.

  • Just confirming that this behavior is indeed the default one for me as well. I'm using GNOME 3.8 as well as Nautilus on Fedora 19. – slm Jul 6 '14 at 6:09
  • Have you tried these suggestions? askubuntu.com/questions/80969/… – slm Jul 6 '14 at 6:18
  • Sadly the extension on the page doesn't work and the accepted answer seems not to apply since I don't even use metacity (not a listed item in gconf) – Deryck Jul 6 '14 at 6:43
  • @slm PS - not using metacity or compiz – Deryck Jul 6 '14 at 7:15
  • Not finding much else for this, I might be inclined to see if I was able to fix the extension myself using it as a base if it's annoying me enough 8-). Asking this in an official GNOME forum/bugtracker would be my next step too. – slm Jul 6 '14 at 15:06
4
+200

For some apps (e.g. file-roller) this can be fixed by changing the StartupNotify key value from true to false in their respective .desktop files (e.g. /usr/share/applications/file-roller.desktop).

The above doesn't work for all apps (e.g. nautilus) so another way to fix the problem would be a custom shell extension; just to give you an idea, you could easily fix nautilus behavior like this: edit /usr/share/gnome-shell/js/ui/windowAttentionHandler.js and add these three lines of code:

    if (app.get_id() == "nautilus.desktop")
        Main.activateWindow(window);
        return;

after the following line:

    let app = this._tracker.get_window_app(window);

so you end up with something like this:

    let app = this._tracker.get_window_app(window);
    if (app.get_id() == "nautilus.desktop")
        Main.activateWindow(window);
        return;
    let source = new Source(app, window);
    Main.messageTray.add(source);

However, it's not worth writing your own extension unless you want to target only some specific applications. For a global change it looks like there is an extension:

just show the window

that overrides the "notification system" (it works fine here on gnome 3.8).
Keep in mind the two files (extension.js and metadata.json) have to be placed in:
~/.local/share/gnome-shell/extensions/justshowthewindow@ryanlerch.org
Activate the extension via tweak-tool and restart the shell (Alt+F2 then r then Enter).

  • it blows my mind that this is so hard to accomplish without knowledge of gnome-shell inner-workings and/or extension development. Super freaking glad to be rid of the issue though. Thanks again my sanity owes you big time. – Deryck Jul 24 '14 at 22:09
  • 1
    @Deryck - starting with Gnome 3.12 one will no longer be able to hack shell js files for a quick fix: the shell will be a single binary and as such the only way to customize it will be via extensions. Just so you know... – don_crissti Jul 27 '14 at 19:12
0

this issue has appeared in other forums on different versions of Ubuntu and people using gnome. the easiest way to fix the issue is make sure that you have Compiz Config Settings Manager installed.

sometimes the install never is done right and the manager has to be re installed.

to install it search for compizconfig-settings-manager in Software Center and install from there or type in your terminal sudo apt-get install compizconfig-settings-manager

once that is done go to system tools > preferences > compizconfig

Go at the very bottom where it says windows management and put a check mark in it. that should fix the problem

  • 1
    I will test this on my laptop with a new install first but even if it helps, installing compiz is quite a drastic step to take for such a small (yet incredibly painful) issue. Thanks for the idea I'll let you know if it helps. – Deryck Jul 23 '14 at 23:38
  • 1
    I have found the answer in the comment by @don_crissti. Thank you for your post. – Deryck Jul 23 '14 at 23:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.