1

I just use Linux for a LAMP server. I'm currently installing Apache 2.4 on CentOS 6.4 (x64).

How do I resolve this error below?

rpmbuild: arguments to --root (-r) must begin with a /
[root@microtrack src]# rpmbuild --rebuild /distcache-1.4.5-23.src.rpm
error: cannot open /distcache-1.4.5-23.src.rpm: No such file or directory
  • change rpmbuild -rebuild to rpmbuild --rebuild and try. – Ramesh Jul 3 '14 at 18:39
  • FYI: The error shows below the command. So your picture doesn't show the command that gave the "arguments to --root" error. – derobert Jul 3 '14 at 18:51
  • 1
    Please don't post screenshots of text; post the text itself... – jasonwryan Jul 3 '14 at 19:06
5

rebuild needs two dashes, not one. --rebuild.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.