3

I setup the simplest outgoing email server possible with ssmtp. It is giving me the error Authorization failed (535 Authentication credentials invalid). Here is my configuration without comments:

# /etc/ssmtp/ssmtp.conf
root=myemail@gmx.com
mailhub=mail.gmx.com:465
rewriteDomain=gmx.com
hostname=HP-Q101
rewriteDomain=gmx.com
FromLineOverride=YES
AuthUser=myemail@gmx.com
AuthPass=my@super&secret*pa$$word
UseTLS=YES

Running output:

~$ ssmtp -vvv webmaster@example.com < msg
[<-] 220 gmx.com (mrgmxus001) Nemesis ESMTP Service ready
[->] EHLO ASUS-N53SM
[<-] 250 AUTH LOGIN PLAIN
[->] AUTH LOGIN
[<-] 334 VXNlcm5hbWU6
[->] c3VwZXZvMZExZGdteZ3jb33=
[<-] 334 ZZFzc3dvcmZ3
[<-] 535 Authentication credentials invalid
ssmtp: Authorization failed (535 Authentication credentials invalid)

I understand that this implies a wrong username or password, but I have confirmed the password by copying it directly from my password manager. I also tried setting my user name to only myemail.

  • Anyone have luck setting up a GMX account?
  • If the problem isn't username/password, what could it possibly be?
  • Maybe you need STARTTLS? – fkraiem Jul 4 '14 at 13:20
2

Change your config to match this:

# /etc/ssmtp/ssmtp.conf
root=youremail@gmx.com
mailhub=mail.gmx.com:587
rewriteDomain=gmx.com
hostname=gmx.com
FromLineOverride=YES
AuthUser=youremail@gmx.com
AuthPass=yourpassword
UseSTARTTLS=YES

Source:
https://help.gmx.com/en/applications/pop3.html

  • Dead link. Also what's the point of having twice the rewriteDomain setting? – vmonteco Jan 2 '18 at 12:13
  • There is no point of having it twice. I have corrected the typo – Rucent88 Feb 16 '18 at 21:03
0

In case someone else has still had this authentication problem even after the config file was changed to what Rucent88 proposed, the problem I had was with a complicated password for my GMX account, with special characters like punctuation, brackets, number sign, etc.

Maybe the parsing of the ssmtp.conf file isn't that great, anyway I changed it to something alphanumeric, and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.