2

APR 2015 UPDATE: Scanning just worked! The update to Mint 17 (aka Ubuntu 14.04) did not make any difference, but the most likely explanation is that the recent update to Ubuntu 14.04.2 as the base distro fixed something.

(I haven't installed anything fresh from Brother, and I haven't touched any of the config files, in months. It is also the first time I tried scanning in months, so I don't think I can narrow anything down to self-answer this question. My kernel is "Linux len 3.13.0-24-generic #47-Ubuntu SMP")


I'm having awful trouble getting a DCP-7055 multi-function printer to work as a scanner with Mint 16. (My old flatbed scanner was working.) (I have printing working.) I've installed the Brother scanner drivers.

As a normal user, in simple scan, clicking scan immediately says Failed to scan. Unable to connect to scanner. If I run it as root it takes 15 seconds before saying Failed to scan. unable to start scan

I found this comment and for me scanimage -L says:

device `brother4:bus2;dev3' is a Brother DCP-7055 USB scanner

However ls /dev/bus/usb/002/ only lists:

001  002

I.e. I think /dev/bus/usb/002/003 ought to exist, and doesn't, and that might explain everything?? But, now I've reached the end of my knowledge: what do I do about this?

UPDATE: Or maybe this is a red herring... after plugging the scanner into a different USB port, scanimage -L says:

device `brother4:bus2;dev1' is a Brother DCP-7055 USB scanner

But that exists:

crw-rw-r-- 1 root root 189, 128 Jul  2 22:16 /dev/bus/usb/002/001

Yet simple-scan gives exactly the same behaviour for both normal and root users.

  • Did you install the Brother drivers? – Faheem Mitha Jul 2 '14 at 21:54
  • @FaheemMitha Yes (see first paragraph). In fact, once I finally had printing working, I also tried uninstalling them and installing them once more. – Darren Cook Jul 3 '14 at 7:13
  • Ok. Sorry about my poor comprehension skills. – Faheem Mitha Jul 3 '14 at 8:10
  • @FaheemMitha No problem. Using the latest Brother drivers was the key to getting printing working; the driver that Mint/CUPS suggested did not work. – Darren Cook Jul 3 '14 at 8:22
  • Darren, did you do any configuration besides installing the drivers? My recollection was that there was at one and maybe more configuration step that had to be done. Can you list what additional steps you took besides actually installing the drivers? One thing I did was add the file /etc/sane.d/dll.d/brother containing just the word brother4. I'm pretty sure the brother drivers didn't add this. – Faheem Mitha Jul 3 '14 at 8:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.