2

I keep getting these log warnings due to a bug in kvm.

Jun 30 19:12:31 server kernel: kvm: 28882: cpu0 ignored rdmsr: 0x345
Jun 30 21:12:31 server kernel: kvm: 31191: cpu0 ignored rdmsr: 0x345
Jun 30 23:12:31 server kernel: kvm: 1107: cpu0 ignored rdmsr: 0x345
Jul  1 01:12:31 server kernel: kvm: 3583: cpu0 ignored rdmsr: 0x345
Jul  1 03:12:31 server kernel: kvm: 5940: cpu0 ignored rdmsr: 0x345
Jul  1 05:12:31 server kernel: kvm: 8409: cpu0 ignored rdmsr: 0x345
Jul  1 07:12:31 server kernel: kvm: 10682: cpu0 ignored rdmsr: 0x345

I tried changing values in printk file from default to 3 3 1 3 so that only critical logs are written in /var/log/messages. But these warnings won't go away.

Any idea to get rid of these warnings?

1

1 Answer 1

1

I guess you have to edit your /etc/rsyslog.conf file by commenting the 9th line:

$ModLoad imklog   # provides kernel logging support (previously done by rklogd)

and then you have to restart rsyslog service:

#/etc/init.d/rsyslog restart
1
  • 1
    the command disables all kinds of kernel logs. Is there a command to disable only certain kernel logs?
    – Purres
    Jul 8, 2014 at 19:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .