1

I wanted to boot a Mint 17 live CD, but I did not have a blank CD lying around so I "installed" the live CD on a newly created partition.

Now my laptop always boots into Mint, but I want to boot back into Windows.

I tried to press C to enter GRUB (at least that's what I think it's called) and the first option is to boot into Linux. The last option is to boot from local drive. But whatever choice I make, it keeps booting Linux keeps booting.

  • 2
    I've posted an answer, but for what it's worth - in the future, don't do that. just buy some CDs. they're really cheap nowadays. – strugee Jul 2 '14 at 19:17
  • 1
    How exactly did you "install" the live CD to a partition? Are you sure you ended up with GRUB as your bootloader? – depquid Jul 3 '14 at 21:00
  • @depquid i used Universal USB Installer on a partition i created in windows. well i think i endedwith grub s bootloader but i can't be sure. i think that's the bootloader used by uui. how could i check? – jurgees Jul 5 '14 at 18:20
  • I'm not familiar with the details of that installer, but it's probably only designed to create an installation disk with a single partition, in which case there's good chance it ruined your Windows bootloader and you'll need to repair Windows as @strugee explained. – depquid Jul 7 '14 at 15:06
1

Boot from your Windows DVD. If you bought Windows separately from your computer, then this is the DVD you bought. If Windows was preinstalled on your computer, then the DVD most likely came in the box. If it did not, contact your manufacturer to see if they will give you one. Once you have booted the DVD, find the option that says something like "repair startup" and select it. This will overwrite GRUB with the Windows bootloader. You may now reboot and remove the Windows DVD. You can delete the Mint partition from Windows.

| improve this answer | |
  • /usr/sbin/grub-probe : error: failed to get canonical path of '/cow'. – jurgees Jul 2 '14 at 19:42
  • @jurgees that shouldn't be a problem. if it still doesn't work (which I suspected all along), you will need to use option number one. – strugee Jul 2 '14 at 19:48
  • 1st option also does not work. I have set up 1st boot priority device and it still does not want to boot from the win cd. Isn't there anyway to make grub to see my win partition? – jurgees Jul 5 '14 at 20:04
  • @jurgees at that point it isn't a problem with GRUB. if you really couldn't boot your Windows DVD, you have run into a bug in your BIOS. I would recommend contracting your manufacturer or asking on Super User. but I highly doubt this is the case - are you sure you set the boot order correctly? – strugee Jul 6 '14 at 5:18
  • 1
    @strugee Or the DVD is faulty. – depquid Jul 7 '14 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.