1

I'm using Gnome Keyring with GPG. Whenever I need to sign something, the keyring daemon takes over and does it for me.

However, if I do: export GNUPGHOME=/path/to/keyring from a Bash script and use gpg in that script, the keyring daemon doesn't take over.

Why is this? How can I change this, so that the keyring is used for other $GNUPGHOMEs as well?

If I run seahorse, I can see that the password for the keys that exists in /path/to/keyring is there.

0

Solved it!

The problem was that the option use-agent wasnt enabled.

I had previously uncommented use-agent in ~/.gnupg/gpg.conf to be able to use the keyagent for my default keyring.

BUT, since I changed the homedir of the keyring, gpg was looking for a config in /path/to/keyring/gpg.conf instead and found nothing, since I only moved pubring.gpg and secring.gpg when I exported the keyring.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.