0

I just installed EasyBCD for my dual boot laptop (Windows7 and Ubuntu 14.04). Everything works great, however if I choose the Ubuntu option on loading, the next screen it takes me to is GRUB2 with the options of Windows and Ubuntu. How do I bypass that screen so that it bypasses the Linux bootloader and goes right into Ubuntu

When I edited the grub file as suggested and run a sudo update grub this is what I get:

Found linux image: /boot/vmlinuz-3.13.0-27-generic
Found initrd image: /boot/initrd.img-3.13.0-27-generic
Found linux image: /boot/vmlinuz-3.13.0-24-generic
Found initrd image: /boot/initrd.img-3.13.0-24-generic
Found Windows 7 (loader) on /dev/sda3
done`

When I restart it, the grub still appears as the same.

3
  • How about and just remove EasyBCD... you don't need it.
    – Braiam
    Jul 1, 2014 at 22:03
  • Because the grub2 is not loading to windows properly. Every attempt I made at fixing the grub has not resolved the issue i was experiencing. When I installed EasyBCD, it gave better results.
    – ryekayo
    Jul 1, 2014 at 22:05
  • And I dont even know why this is being down voted in the first place.
    – ryekayo
    Jul 1, 2014 at 22:07

3 Answers 3

3

Try changing the values that are in etc/default/grub to look like these:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Then run sudo update-grub.

1
  • That didnt work
    – ryekayo
    Jul 1, 2014 at 20:40
1

I don't think there's a way of bypassing GRUB2 (or any other Linux bootloader) via EasyBCD. Most probably EasyBCD is not a universal bootloader and it works by chain loading into GRUB2.

Your best bet is to try and make GRUB2 timeout on the Ubuntu entry immediately as Jonyburd's answer is suggesting. I believe you should look into why it failed.

6
  • How can i find out why it failed?
    – ryekayo
    Jul 1, 2014 at 21:52
  • @ryekayo The first place to look would be /boot/grub/grub.cfg which is created by update-grub. You need to make sure that the Ubuntu entry has set timeout 0 as expected.
    – Joseph R.
    Jul 1, 2014 at 21:56
  • I see two blocks of code as to where to set timeout I will add that to my question.
    – ryekayo
    Jul 1, 2014 at 21:58
  • 1
    @ryekayo You should not edit /boot/grub/grub.cfg by hand. Any edits you make will be silently clobbered the next time you run update-grub or update the GRUB2 package (which causes update-grub to be run). Restrict your edits to /etc/default/grub and files in /etc/grub.d
    – Joseph R.
    Jul 1, 2014 at 21:59
  • Ok then how do i set the timeout as mentioned
    – ryekayo
    Jul 1, 2014 at 22:01
0

For anyone running in a similar problem, where setting GRUB_TIMEOUT=0 didn't help:

In my case the grub os-prober had overwritten the GRUB_TIMEOUT to 10, whatever value I might have set in /etc/default/grub.

If you don't need the other OS entries in grub (because you have two chained bootloaders as here or your BIOS already has kind of a boot menu) disabling the os-prober in /etc/default/grub might help:

GRUB_DISABLE_OS_PROBER=true

If you need these entries though, you probably have to edit /etc/grub.d/30_os-prober

See: https://help.ubuntu.com/community/Grub2/Setup#Specific_Entries

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.