I connected to a Linux system using the putty SSH client on my Windows PC. Now it's unable to open a PDF document in putty. The error message:

gnome-open .pdf

(gnome-open:4137): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Unable to autolaunch a dbus-daemon without a $DISPLAY for X11
GConf Error: No D-BUS daemon running

How can I open this document for viewing?

4 Answers 4


GUI applications under Linux require that a X server be available to drive a system's displays/monitors. Part of the responsibility of the X server is to accept/deny connections from applications that require access to the display/monitor.

In your case you're running PuTTY on Windows so there is no X server to provide access for these GUI applications, so you're encountering an error message to that effect.

There are several options available to you, one such option would be to use Xming (sourceforge site & main project's site).

   ss #1

There are of course other options which provide an X server for Windows.

  • As slm menstioned, there are other options than xming. The one I like most is MobbaXterm (mobaxterm.mobatek.net), because it includes many features in one small download and no need for installation (i.e. admin permissions).
    – ph0t0nix
    Aug 14, 2014 at 11:04

You said: "Now it's unable to open a PDF document in putty". Was it ever able to open the pdf file in the first place, or you are trying this for the first time?

As per the error, I can see that you don't have a valid display. Run the following commands to see if you have an X server (and proper display) running:

ps -e | grep X

If no results, then you are not running a display, so you have to fix that first.

Also, opening the file like that (gnome-open file.pdf) will trigger the action in the server you are connected to, so don't expect to see the file through your putty session. I guess there are ways to make that work, but I'm afraid that's not an out-of-the-box feature. Maybe you can connect to the server's X using VNC?


You need to install X server on your windows PC to be able to see the output. Here is a link for one of the X Server software. after installing this then you can set your DISPLAY option to output to your windows PC

example to set the display option :

export DISPLAY=${XSERVER}:0.0

  • where to set a PATH
    – Poke
    Jul 2, 2014 at 3:10
  • ** (evince:2528): WARNING **: Could not open X display Invalid MIT-MAGIC-COOKIE-1 keyCannot parse arguments: Cannot open display: THIS type of error
    – Poke
    Jul 2, 2014 at 3:25
  • It might be the permission issue. run xhost + this will allow remote to send display
    – Raza
    Jul 7, 2014 at 18:05
  • by the way, sorry about the delay in responding.
    – Raza
    Jul 7, 2014 at 18:06

This answer offers a way to open a PDF (which is on a server connected to through PuTTY), not directly through the terminal, but by mounting a remote folder (directory) as a virtual drive on your PC.

The following instructions has been adopted from this page.

You need to first install the latest release of WinFsp.

Then install the latest release of SSHFS-Win.

Now you can mount your favorite directory of the remote machine as a disk drive on your Windows machine: in Windows Explorer right click on This PC and select Map network drive. Pick a drive name, for example, X:. Then enter the full address of your favorite directory according to the following syntax.


You most probably want to check the box to Connect using different credentials as you are likely to use a different user and password for the remote machine than that of your PC.

After you click Finish, you will be prompted for the user and password of the remote machine. You may want to let the Windows Credential Manager to save the user and password only if you are sitting behind your own PC, not a public machine.

Map Network Drive

Now you can see the mounted drive in your Windows Explorer. So you can open any file including PDFs by just double clicking on them!

NOTE: A good thing about mounting a remote drive as descried above is that it also works on a public PC as you do not need to have the administrator password for the Windows.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .