4

I have installed Linux Mint 17 and Windows 8, as dual boot. 500GB hard disk has 5 partitions. Two of them are NTFS and the other 3 are ext4 partitions.

When I log into Windows, I can not see any ext4 partition, only NTFS partitions.

When I am on Linux, I can see all partitions. But when I go and try to give execution permission to files in NTFS, it cannot be done. No error message appears, but the permissions are not changed.

How can I give the execution permission to a file on a NTFS partition?.

  • Ho do you mount the NTFS partitions? If via /etc/fstab, please show the contents in the question. – SkyDan Jul 1 '14 at 6:45
1
  • You need a ext4 driver for Windows to be able to see an ext4 partition.

  • NTFS does not have Linux-style attributes, so any permission change is implemented as a no-op in NTFS file system module. To execute something on a NTFS partition you have 2 choices:

    1. Mount the partition with exec option, which makes all files on the partition executable. So your /etc/fstab/ entry might be like:

      /dev/sda2  /media/partition ntfs-3g defaults,exec 0 0
      
    2. Copy the file to a partition supporting Linux-style attributes, run chmod +x file and execute it.


You might also want to look at man mount to see what different options are and build an options line that matches your needs best.

  • From what I remember ntfs does have an execute bit, bit Microsoft in there wisdom decided to set it on all files. (they did this to improve comparability with there older OSs and to aid in the spread of viruses. – ctrl-alt-delor Jul 16 '16 at 22:17
1

Since NTFS doesn't support Linux permissions, your only option is to enable execution of all files on the partition. This must be done when you mount the partition.

mkdir ntfs
sudo mount -o fmask=000 /dev/sda2 ntfs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.