2

I recently bought a USB to DVI adapter and it works great in Windows.

However, I wanted to use it on Arch since that's where I do most of my work.

Unfortunately it doesn't work.

I've installed all the packages, added udl, and blacklisted udlfb as directed by the wiki.

However when I run xrandr --listproviders it returns this:

Providers: number : 1
Provider 0: id: 0x47 cap: 0xb, Source Output, Sink Output, Sink Offload       crtcs: 3 outputs: 5 associated providers: 0 name:Intel

Furthermore dmesg shows this for the USB device:

[ 1905.126686] usb 2-1: new high-speed USB device number 10 using ehci-pci
[ 1905.254243] usb-storage 2-1:2.0: USB Mass Storage device detected
[ 1905.254552] scsi9 : usb-storage 2-1:2.0
[ 1906.258054] scsi scan: INQUIRY result too short (5), using 36
[ 1906.258075] scsi 9:0:0:0: CD-ROM                                              PQ: 0 ANSI: 0
[ 1906.261289] sr1: scsi3-mmc drive: 8x/40x writer xa/form2 cdda tray
[ 1906.261747] sr 9:0:0:0: Attached scsi CD-ROM sr1

It looks to me like it thinks my display device is a USB-storage device.

EDIT: I just now found out that the device mounts as a storage device with the drivers on it. I guess this would explain why it says it's a storage device, but it still doesn't help me solve the real problem.

So, my questions are:

  • Is there a way I can fool it into loading the correct driver/kernel module for it? I think the display link driver will work with it, if I can just find a way to have arch load it.
  • Do I need to do something in the Xorg config?

Also in case it's relevant:

  • My window manager is xfce4
  • I'm trying to set up a third monitor
  • I have an Intel graphics card

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.