0

After a fresh installation of Manjaro Linux and selecting 2 languages for the system, I can't access the us english layout anymore!

I have selected the Alt + Shift in order to change layout but it doesn't work.

I can't login, I have rebooted and the problem persists. How do I set the default us layout?

  • Did you tried super + space? What DE you use? – Braiam Jun 29 '14 at 19:51
  • @Braiam:No , it doesn't work.I am using KDE.Is there a way to access a file responsible for the language from a live cd?Or from another distro?(I have 2 linux installed) – George Jun 29 '14 at 19:54
  • @George, Is this link helpful? wiki.archlinux.org/index.php/locale – Ramesh Jun 29 '14 at 20:02
  • @Ramesh:I changed the locale.conf to LANG=en_US but still the same.Also,I noticed that during boot it says "FAILED: setup keyboard layout" – George Jun 29 '14 at 20:18
  • @George, I have not tried it out. But you can check this link as well. askubuntu.com/questions/380746/… – Ramesh Jun 29 '14 at 20:31
1

On the Manjaro Linux Keyboard Layout page, you will find that they build the keyboardctl utility which makes it possible to change both the console and X11 keyboard layout at once, like so:

sudo keyboardctl -l us

For X only, you would use setxkbmap us (session) or kbctl -l us (permanent). In the console, you would do loadkeys us (see /usr/share/kbd/keymaps/i386/) (session) or you would edit /etc/vconsole.conf to include KEYMAP=us to implement the change permanently which should make things easier in the context you described.

Manjaro also uses the systemd system management daemon and is based on Arch so the Arch Linux documentation may provide different but complementary information.

  • :The problem is that when I am running a command (like keyboardctl) it executes in my other linux distro (not manjaro) because I am just mounting the manjaro filesystem from my othe rlinux distro.How can I overcome this?Running from live cd is still the same?(I can't try it right now , I will later).Thanks! – George Jul 1 '14 at 7:36
  • :I have already done this. – George Jul 1 '14 at 9:33
  • :Yes!It didn't work.I figured..I did format :) .Hopefully it was a fresh install.Thanks for your help. (upvoted) – George Jul 1 '14 at 19:04
  • 1
    :Ok, I will try it.But from next week because I don't want to risk it right now :) .Thanks – George Jul 2 '14 at 7:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.