1

I have a Lenovo B5400 with Ubuntu 14.04 x64. The Ethernet port works fine. How can I enable/disable the WiFi connection? I have no hardware button for this functionality. Under Windows I can press Fn+F5 and a dialog window appears, but I cannot find this functionality under Linux.

lspci | grep Network produces:

04:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

The answer from here is incomplete. Any other ideas?

EDIT #1: The output of rfkill list all is:

0: tpacpi_bluetooth_sw: Bluetooth
    Soft blocked: yes
    Hard blocked: yes

1: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no

2: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes

PS: disclaimer: crossposting

  • 1
    Even if your wireless card is disabled, it will be shown by lspci, because lspci is supposed to show all hardware connected. When rfkill says that it is hard blocked, that should mean it has been disabled at the hardware level. When I press Fn + F5 in my Linux system, no dialog appears, but the kernel disables or enables the wireless card. Try pressing Fn + F5 again and checking the output of rfkill list all. – Teresa e Junior Jun 29 '14 at 12:08
  • Thanks for the comment. The Fn+F5 does not change the rfkill output, I still get the "Hard blocked: yes" status. If I press that combination in Windows and then reboot in Ubuntu, the phy0 interface now appears as "Hard blocked: no". Clearly, I would like to avoid these OS switches. – lmsasu Jun 29 '14 at 12:15
  • Try rfkill unblock wifi as root. – Teresa e Junior Jun 29 '14 at 12:19
  • 1
    And sudo rfkill unblock phy0 or sudo rfkill unblock wlan? – Teresa e Junior Jun 29 '14 at 12:21
  • 1
    If that's difficult for you = If you have the time or bandwidth available. There are many user friendly LiveCDs out there that you can use just to test your hardware without installing them, like Debian, which is very stable, and openSUSE or Mageia, which are more bleeding-edge. There is also Mint, which is well known for being very user friendly, but I don't know whether it uses the Ubuntu kernel or not. – Teresa e Junior Jun 29 '14 at 15:10
-1

I had same problem with my lenovo. Running the following solved my issue:

$ sudo modprobe -r ideapad-laptop
$ sudo rfkill unblock all
$ rfkill list all
  • Consider adding explanations (or documentation links) for each command for completeness. – HalosGhost Aug 11 '14 at 0:03
  • Thanks for the answer. Unfortunately, I still get: 0: hci0: Bluetooth Soft blocked: no Hard blocked: no 1: tpacpi_bluetooth_sw: Bluetooth Soft blocked: no Hard blocked: yes 2: phy0: Wireless LAN Soft blocked: no Hard blocked: yes – lmsasu Aug 12 '14 at 4:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.