I'm having a weird issue with my Debian Wheezy desktop. When I try to shutdown the system (either from Gnome or from the command line with shutdown -h now) the computer automatically reboots.

The weirdest thing is that the last message before rebooting is "Will now halt"... and a few seconds later, the computer restarts. After waiting for the system to start, if I issue shutdown -h now from the console (before starting GNOME), the computer shutdowns cleanly, and stays off.

Although I know that I could leave the computer on indefenitely (after all, this is not a Windows box), I prefer to shut it down properly.

Is there some configuration file and/or option I should look at to solve this issue?

Background info

  • Debian 7.5 "Wheezy" 64 bit
  • Processor: Intel Core i7
  • Motherboard: ASUSTeK P8B75-M
up vote 3 down vote accepted

This thread had many suggestions that look like good leads for you to follow up with.

Things to try

idea #1 - systemd

If your system uses systemd try using this:

$ systemctl poweroff
idea #2 - blacklist kernel module mei_me

This mei_me ( Intel Management Engine Interface) for Mobile Intel Express Chipset, causes a lot of trouble.

You can blacklist the module, you could lose functionality that I'm not aware of.

If your laptop supports it you may be able to disable it in your BIOS. I read people having success disabling it, though their all different issues.

idea #3 - interrogate journalctl boot messages

Take a look at the journalctl for feedback on what's causing the system to reboot.

$ sudo journalctl -b
idea #4 - Add kernel parameter acpi=force

Try adding the following to your kernel's boot parameters. These can be appended to the end of your kernel's line in /etc/grub2.cfg.

linux   /vmlinuz-3.14.4-100.fc19.x86_64 root=/dev/mapper/fedora_greeneggs-root ro rd.md=0 ... acpi=force ...
idea #5 - Try a different power supply (larger rated)

My power supply was 450W. However, I got tired of going around the head until I read on page 23 of the GA-Z87N-WIFI manual which case we use the PCI-E was advisable to use a power supply of 500W or higher, as lower springs would destabilize (possible cause of the reboot).

Made to upgrade to a 650W power supply and reboots after shutdown, never happened.

Conclusion: new graphics cards are hungry for energy. Always check the power requirements of the printing and adjust energy sources.

idea #6 - disable WOL (Wake On LAN)

By default, the Wake-up LAN is enabled in BIOS (Power Manegement). As I have a Synology NAS configured for my private network, the "trickster" is sending packets to the network and enables me to Linux machine after doing this shutdown.

I followed your recommendation (I disabled the Wake-up LAN) and everything works as expected.

idea #7 - bug in kernel with xhci module

xhci: Fix spurious wakeups after S5 on Haswell

Source Bug 66171 - [PATCH]Poweroff doesn't work, it just reboots

I had this problem on my Fedora 22 and Arch installation. After reading this bug report I added xhci_hcd.quirks=262144 to my /etc/default/grub boot options.

  • Tried all of the above options. This was the only thing to work. – branch.lizard Sep 24 at 19:19

I have the same problem and none of the solutions above worked for me. turns out it was this bug The workaround mentioned there worked for me:

dpkg --purge kexec-tools

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.