2

I'm installing Arch Linux, following the instructions at the Beginners' Guide, and got up to running pacstrap -i /mnt base base-devel.

It finishes with the following error:

resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: virtualbox-guest-modules: requires linux<3.15
==> ERROR: Failed to install packages to new root

What is really weird is that I'm not installing Arch in a virtual machine, I'm setting it up to dual boot on my laptop.

  • does it still happen if you omit base-devel? Arch doesn't just install things on its own, you must have pulled it in somehow. are you sure that's the exact command you typed? – strugee Jun 27 '14 at 17:50
  • It still happens if I omit base-devel. I am installing over a previous Linux distro if that effects anything? – Peter Jun 27 '14 at 17:53
  • it shouldn't affect anything, but there can't be any harm in getting rid of it. is your /home on the same partition as the other distribution? if not, personally I would nuke the filesystem, just to be safe. this is very weird. – strugee Jun 27 '14 at 17:55
  • Well, strangely enough that worked. Thanks! – Peter Jun 27 '14 at 18:06
1

I was installing arch Linux over a previous Linux installation. Once I'd wiped the filesystem it all worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.