390

I couldn't find in google any safe way to clear systemd journal. Do anyone know any safe and reliable way to do so?

Let's say I was experimenting with something and my logs got cluttered with various error messages. Moreover I'm displaying my journal on my desktop by using Conky. I really don't want to see those errors as they remind me an awful day I was fixing this stuff, I want to feel like a fresh man after this horror. I think everyone will agree that this is a valid reason to clear the logs :P .

1
  • 1
    This is the top search result when looking for a way to clear journal entries. However, none of the answers below actually answer the question, because they either delete old logs or all logs. None of them are about clearing recent or specific logs. I posted a guide for deleting specific log entries at unix.stackexchange.com/questions/272662/… – Rob W Oct 27 '20 at 23:00

13 Answers 13

546

The self maintenance method is to vacuum the logs by size or time.

Retain only the past two days:

journalctl --vacuum-time=2d

Retain only the past 500 MB:

journalctl --vacuum-size=500M

man journalctl for more information.

10
  • 15
    Nice command, but didn't work for me on openSUSE 13.2 (the current stable release). It's known that Arch is usually at the cutting edge when it comes to kernel and userland programs, so I speculated that vacuum options might have been recently added to systemd and simply haven't precipitated down into my distro. Confirmed the fact here in Lennart's announcement on Dec 10 2014 techupdates.com/go/1002774 that this command was added in systemd v218. Just adding this comment incase any one else like me who is not on Arch has a similar issue. Upvoted anyway. – Joshua Huber Apr 23 '15 at 0:33
  • 8
    Didn't work in version "systemd 229" on Ubuntu 16.04. journalctl --vacuum-size=1K then journalctl still shows way more than 1K. It shows all the messages since the last boot. – Dan Dascalescu Sep 10 '16 at 4:23
  • 36
    It seems that this only clears archived logs, not active ones. I tried running journalctl --flush --rotate before journalctl --vacuum-time=1s and it removed more stuff, although still not everything. – user60039 Feb 7 '17 at 19:42
  • 3
    The documentation doesn't seem so clear to me. Does it always stay set to 2d (in your example)? Or is 2d from the time you run the command? Maybe I'm not understanding how this works exactly. – jersey bean Aug 3 '17 at 1:49
  • 2
    Careful though, I used sudo journalctl --vacuum-time=7d and was only left with logs from today... Seems like a buggy feature – EarthMind Apr 15 '19 at 19:57
156

You don't typically clear the journal yourself. That is managed by systemd itself and old logs are rotated out as new data comes in. The correct thing to do would be to schedule journald to only keep as much data as you are interested in. The most usual thing to adjust is the total disk space it is allowed to take up. Once it crosses this boundry it will start pitching old entries to stay near this value.

You can set this in /etc/systemd/journald.conf like so:

SystemMaxUse=100M
6
  • 16
    Ok, but there are also untypical situations. I know that most of them is just aesthetics as a reason, but aesthetics is a valid reason for human being ;) . – Łukasz Zaroda Jun 27 '14 at 12:08
  • 4
    @ŁukaszZaroda In that case you are going to have to define "safe". Normally "I want to blow away something that a daemon is configured to keep" is incompatible with "safe". If you want to force it just shut down the service and zero out the log files. If you want it to work normally you should define the parameters in your question better. What do you mean by "safe"? – Caleb Jun 27 '14 at 12:17
  • 1
    By safe, I mean that after clearing it will work as usual, just starting from the new place. – Łukasz Zaroda Jun 27 '14 at 12:19
  • 5
    It may be not typical situation but sometimes it is necessary to delete old logs due to some systemd's bugs, e.g. bbs.archlinux.org/viewtopic.php?pid=1173031#p1173031 – anlar Jun 27 '14 at 15:57
  • 9
    To clean logs after a period of time rather than when they reach a certain size, you can set the parameter MaxRetentionSec instead of SystemMaxUse. See man journald.conf for more details. – joelostblom Mar 29 '18 at 13:08
133

Michael's answer is missing one thing: vacuuming only removes archived journal files, not active ones. To get rid of everything, you need to rotate the files first so that recent entries are moved to inactive files.

So, the complete answer to remove all entries seems to be

journalctl --rotate
journalctl --vacuum-time=1s

(Note that you cannot combine this into one journalctl command.)

By the way, some distributions have journald configured so that it writes logs to disk (/var/log/journal) while others keep logs in memory (/run/log/journal). I expect that in some cases it may be necessary to use journalctl --flush first to get everything removed.

If you don't have --rotate in your version, you can use the --since argument to filter entries:

--since "2019-01-30 14:00:00"
--since today
4
  • 5
    journalctl: unrecognized option '--rotate' – stiv Oct 7 '18 at 12:22
  • 11
    while I get what the other answers are approaching (long term strategy) - the question is simple: how do you clear logs now (maybe you're not interested in the long term for your current task). This answers that question without making other assumptions and adds other great value to understanding journalctl. This should be the answer. – Marc Oct 20 '18 at 15:39
  • 3
    Original question was "how do I reset my logs for debugging purposes". This is the only answer that addresses that. And I'm really glad I found it. The rest are interesting journalctl factoids, but not answers to the questions. – Travis Griggs Oct 25 '19 at 19:08
  • Note that this is a one-off command. It sounded to me like it would permanently set the vacuum time to 1 second, but no, this just removes current logs without changing your configuration (which is what I wanted). – Luc May 26 at 12:13
27

On Arch linux, the closest I got was:

  • Edit /etc/systemd/journald.conf to set SystemMaxUse=1M
  • Restarting journal: sudo systemctl restart systemd-journald
  • Resetting SystemMaxUse=200M
  • Re-Restarting the journal

On my system, each journal file is 8MB, and the above cleared all but 3, bringing the total size to ~25MB.

My use-case was disabling CoW for BTRFS (just for the journal directory and subdirectories): sudo chattr +C /var/log/journal/*. The problem is, the attribute is only set on newly-created files, thus the desire to flush the journal.

2
  • 5
    Your use-case was actually not needed. The point of disabling CoW on the journal is that it is frequently written to. That is not the case for the old rotated journal files, they just sit there. – Hjulle Mar 31 '15 at 10:03
  • 1
    I've set SystemMaxUse=1K, restarted systemd-journald, but journalctl still shows entries I want gone. How is this progress from flat text files? – Dan Dascalescu Sep 10 '16 at 4:18
21

Since --vacuum-time and --vacuum-size didn't do a thing for me I did the following:

$ sudo find /var/log/journal -name "*.journal" | xargs sudo rm 
$ sudo systemctl restart systemd-journald

It's not right, but it worked.

4
  • On Debian Jessie, the path is /run/log. – Synchro Feb 12 '18 at 18:23
  • 4
    This is the currently correct answer. It would be nice if the journalctl command could do this but it appears unable. – Kevin Lyda Sep 26 '19 at 10:43
  • Some programs do not handle their logs properly and this may break them – 0x777C Dec 26 '19 at 13:42
  • This seems to be the only working command from all the answers here, at least for Ubuntu 18.04. 3 GB of /var/log/journal/* from about 3 years were removed by none of the "vacuum" variants mentioned in other answerd – Dweia Mar 15 at 16:00
17

A very brute force method to clean the entire log:

$ sudo journalctl --vacuum-time=1seconds

You can also use --vacuum-size as Michael mentoined.

3
  • 5
    Didn't work. Entries for 15 minutes ago still show up, even after running systemctl restart systemd-journald. – Dan Dascalescu Sep 10 '16 at 4:15
  • 1
    Same here. This didn't work for me either. I'm running CentOS7. – jersey bean Aug 3 '17 at 1:55
  • From the man page "the vacuuming operation only operates on archived journal files." – Larsen Jul 16 at 10:51
9

Both --rotate and --vacuum-time=1s didn't work for me on CentOS. I was able to clear it like this:

sudo rm -rf /run/log/journal/*
5
  • 1
    I found 2 directories with hexadecimal name in ./journal. The journalctl commands only works in the most recent one. So I had to delete the old directory manually and that is safe. After I just limit the size in journal conf. – KeitelDOG Feb 19 '19 at 20:40
  • On Ubuntu Server 20.04, that folder you mentioned exists, but there was nothing in it (ls -lah /run/log/journal/). – Lonniebiz Aug 2 '20 at 12:25
  • On Ubuntu the directory appears to be /var/log/journal/*. – Eerik Sven Puudist Nov 15 '20 at 20:32
  • Are you sure? What did you do after performing this action and how did you verify? I'm preparing RHEL 7 and RHEL 8 virtual machines for templateing with cloud-init and while loglines with older timestamps appear to be gone I can see the old hostname on the RHEL 7 machine which has no --rotate option. Yes you are messing with journald and delete its files (I'm even restarting journald system unit), but I think systemd in its design to be modern and trustworthy bites back and posts the content it has in memory right back. It might take a reboot, but it's there. – LiveWireBT Jan 30 at 17:32
  • Regarding my previous comment I found that the hostname is compiled in the initrd: unix.stackexchange.com/a/284551/49853 and dracut -f -v solves my problem on RHEL 7. I opted for a solution using find since in some shells or under some circumstances expansion may not work: find "/run/log/journal/" "/var/log/journal/" "/var/run/log/journal/" -type f -delete. – LiveWireBT Jan 31 at 3:13
8

My previous answer just got deleted for being "duplicated". Well, sorry for not being clear enough in my previous answer, but it was different from existing answers. So here's a more elaborated version:

journalctl -m --vacuum-time=1s did the trick for me. Please DO notice the -m flag, it merges all your journals and then clean them up. Without the -m flag, it didn't clean up anything in my case (on CentOS-7).

Hope it helps.

3

journalctl -b will show only from the most recent boot. You can also use -b -1, -b -2 etc. Your horrendous day is still there but you won't have to see it, unless you need to.

1

Also sudo journalctl --vacuum-files 1.

1
  1. Back it up in case if you need it in future:

    cp /run/log/journal/<temp-string>/system.journal /mylog/dir/back/system.journal.bak
    
  2. Clear the file:

    cd /run/log/journal/<temp-string>/
    >system.journal
    
  3. Check to see latest logs:

    journalctl -xe
    
3
  • Clear the file with a cd command? – Alexis Wilke Nov 4 '20 at 21:39
  • @AlexisWilke The cd command is just to navigate to the directory, the next line is bashism which truncates the size of the file to 0 (this answer assumes the shell used is Bash, and doesn't work with things like zsh) – Ferrybig Feb 8 at 13:38
  • @Ferrybig Ah. Now that the formatting was fixed, I can see how that works. Before those two lines appeared on a single line. – Alexis Wilke Feb 8 at 18:32
1

Create this file (and possibly its parent directory): /etc/systemd/journald.conf.d/max-size.conf

With contents:

[Journal]
SystemMaxUse=100M

The space will be freed after you reboot or run sudo systemctl restart systemd-journald

This will keep your journald log small now and forever. Because the config is stored in a dedicated file, there is no editing mess and it's easy to remove the config later (or see what exactly have you changed in the past). You can also specify maximum journal entries time with: MaxRetentionSec=3day

1

I was facing the same situation as you. After some searching, I realize

  1. It is impossible to clear logs for a specific service without 3rd party script.
  2. journalctl --vacuum-time 1s can only clear archived logs. So you may find that the annoying logs still exist after this command.
  3. You can work around this by first journalctl --rotate. This command archives logs immediately so that '--vacuum-time 1s' will take effect.
  4. Actually after 'journalctl --rotate' these annoying logs should have disappeared. So the final answer should be journalctl --rotate.

P.S. Here are relevant parts of journalctl's help

  -N --fields                List all field names currently used
  -F --field=FIELD           List all values that a specified field takes
     --disk-usage            Show total disk usage of all journal files
     --vacuum-size=BYTES     Reduce disk usage below specified size
     --vacuum-files=INT      Leave only the specified number of journal files
     --vacuum-time=TIME      Remove journal files older than specified time
     --verify                Verify journal file consistency
     --sync                  Synchronize unwritten journal messages to disk
     --relinquish-var        Stop logging to disk, log to temporary file system
     --smart-relinquish-var  Similar, but NOP if log directory is on root mount
     --flush                 Flush all journal data from /run into /var
     --rotate                Request immediate rotation of the journal files
     --header                Show journal header information
     --list-catalog          Show all message IDs in the catalog
     --dump-catalog          Show entries in the message catalog
     --update-catalog        Update the message catalog database
     --setup-keys            Generate a new FSS key pair

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.