I like using a fast mouse, so I use xset to speed it up, more than possible with the normal gnome settings.

When I switch to a tty and back to Gnome, my mouse is really slow again (changed to default setting?). Since a while I just open up a terminal, which runs the .bashrc in which I put a xset m <fast> <faster>.

But why does switching change the settings anyway? And how can I stop this behaviour?

Edit: I'm working on a Debian system (might be important concerning some xorg behaviour)

1 Answer 1


It switching because something is detecting the change and setting up the mouse again. (So things go back to default) To stop the behavior you need to add your settings to an Input section in x11.conf so that when it is "re-initilized" the defaults are what you want. The settings your looking for are:

Option "MinSpeed" "X.xx" # speed factor for low movement
Option "MaxSpeed" "y.yy" # maximum speed factor for fast movement
Option "AccelFactor" "z.zz" # acceleration factor for normal movements

  • When I learned something with Linux and Xorg.conf files, then: there are a lot and if the system is paying attention to them, is something totally different... so could you be more specific? Will changing on of those help: /usr/share/X11/xorg.conf.d - 10-evdev.conf / 50-synaptics.conf / 50-vmmouse.conf / 50-wacom.conf Or do I need to add another one or should I look inside /etc/X11 ?
    – PythoNic
    Jun 26, 2014 at 19:42
  • I would edit /etc/X11/xorg.conf but it's different for every system. /etc/X11/xorg.conf (for me) overrides the /usr/share/X11/* stuff. I can put just the InputDevice section and it will work. The "proper way" is probably to edit 10-evdev.conf, but the options will be different.
    – coteyr
    Jun 26, 2014 at 20:22
  • "The options will be different" - so MinSpeed will be called something else? man evdev doesnt even show settings related to this. Your other solution (xorg.conf) doesnt work for me, because there is no xorg.conf and creating via Xorg -configure fails with an error (screens related).
    – PythoNic
    Jun 26, 2014 at 21:08
  • 510x.se/notes/posts/… will help get the properties you need to set, then add them to the evdev file.
    – coteyr
    Jun 27, 2014 at 0:42
  • Thanks, that will help. It seems that xset is working at a different level, so those settings will interfere.
    – PythoNic
    Jun 27, 2014 at 14:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .