3

I'm running Mint 17 Mate on a new HP250 laptop. I can turn off the touchpad by typing the following from terminal:

synclient TouchpadOff=1

Now I want to disable the touchpad automatically each time I log on. I tried adding the above line, exactly as shown, to /etc/rc.local by using sudo gedit, but the system still boots with an active touchpad. I'm not too hot on scripting and I don't know if I've used the incorrect format or if I've chosen the wrong file to add this command to. What is the most suitable script file to use and what should the command look like?

1 Answer 1

4

Create a file (as 'root'): /etc/X11/xorg.conf.d/synaptics.conf and enter the following:-

Section "InputClass"
    Identifier "Touchpad"
    MatchIsTouchpad "yes"
    Driver "synaptics"
    Option "TouchpadOff"  "1"
EndSection

After a reboot, the touchpad shouldn't work. Note, however, that the buttons (if it has physical buttons) will still work.

4
  • I am getting an error on line 5 - "1" is not a valid keyword in this section - and X does not load until I change this line.
    – user277685
    Jun 29, 2014 at 10:46
  • Try putting the 1 in quotes - "1" or try using "On" instead. Jun 29, 2014 at 10:51
  • Changed line 5 to: Option "TouchpadOff" "1" - works nicely now, thanks Gareth.
    – user277685
    Jun 29, 2014 at 11:54
  • This is a good solution but it affects all users. Please add an alternative to disable touchpad on a per user basis (at session startup). I think a .desktop file in ~/.config/autostart would do (so that it runs synclient TouchpadOff=1 or xinput --disable 'SynPS/2 Synaptics TouchPad' where SynPS/2 Synaptics TouchPad is the name of the touchpad device as reported by xinput) Jul 5, 2016 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.