14

I want to check if my server has RAID configured both soft and hard.

I tried some commands on my server (Suse Enterprise Edition 11):

**ms:~ #  cat /proc/mdstat
Personalities :
unused devices: <none>
ms:~ #**

I tried to execute raiddev /dev/md0 but there is no raiddev command available.

Is there any other command that will let me check the raid level of the server?

  • Please review the edited post (once it's approved). There is no need to insert <br> tags. – Tom Zych Jun 26 '14 at 11:44
23

Hardware and Software RAID are two different worlds. Since you mention "Server" most likely there is Hardware RAID present.

to find out use:

lspci -vv | grep -i raid

If Hardware RAID is present the output should be something like:

Subsystem: abcdefg RAID Controller

To find out more about your Hardware RAID configuration, this is only possible using your vendor specific tool. For instance, to get a detailed overview on Dell Hardware, run:

omreport storage vdisk

With an Adaptec RAID controller you can use:

arcconf getconfig 2

All vendors have their own tools. If you have a different vendor install their tool if not yet present. (install DELL OpenManage)

In case of Sofware RAID, for details of raid configuration use:

cat /proc/mdstat

and for details about RAID algorithm, chunk size, RAID level, etc., use:

mdadm -D /dev/mdxx
  • <6>[ 17.041269] mptsas: ioc0: attaching raid volume, channel 1, id 0 What does this line means, any idea? – Özzesh Jul 1 '14 at 6:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.