5

I'm using a Lenovo T430s with an Intel(R) Centrino(R) Ultimate-N 6300 wireless chipset. On certain wireless networks, I experience frequent wifi lockups, which require me to reload the wireless module thusly:

modprobe -r iwlwifi
modprobe iwlwifi

The main clue, aside from lost connectivity, that I need to do this is that dmesg shows:

[ 9351.591170] iwlwifi 0000:03:00.0: Queue 11 stuck for 2000 ms.
[ 9351.591178] iwlwifi 0000:03:00.0: Current read_ptr 153 write_ptr 161
[ 9351.591182] iwlwifi 0000:03:00.0: On demand firmware reload
[ 9351.592001] ieee80211 phy0: Hardware restart was requested
[ 9351.592149] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[ 9351.599072] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
  1. What causes this?
  2. Is there any way to prevent this?

I'm using Linux kernel 3.2.0-4-amd64 from Debian wheezy.

  • It looks like a Hardware/Firmware/Driver failure. Hard to fix, even hard to workaround (except a script that looks for errors in logs and reloads the module). Good luck. – LatinSuD Jun 25 '14 at 18:43
  • Take a look at my A to this Q: unix.stackexchange.com/questions/90687/…. This sounds like a duplicate but will wait for you to try and confirm. – slm Jun 25 '14 at 19:48
  • 1
    @slm: I'll try that. I found another "solution" as well (wd_disable=1), although it seems less than ideal to disable the queue watchdog. Maybe the Wireless N disabling will be better. I'll report back soon. – Flimzy Jun 25 '14 at 19:53
  • Please find a more common word to replace "catatonic" in the title - I see what you mean, but not preciese enough to replace it. Not sure how the medical condition applies... – Volker Siegel Jun 26 '14 at 0:57
5

I found two possible solutions. I'm not sure which one is "best".

Adding wd_disable=1 to the module commandline seems to work, as does 11n_disable=1, as suggested by @slm's answer linked in comments above.

In short, edit /etc/modprobe.d/iwlwifi.conf and add either:

options iwlwifi 11n_disable=1

or

optoins iwlwifi wd_disable=1

FWIW, I'm using the former at the moment, as I know I don't want to use Wireless-N, and disabling a queue watchdog doesn't seem like a good idea.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.