0

I have a USB-HDD, formatted as ext3 connected to my router, so I can use it as a home-network storage. It works quite well, however, when sending a lot of files to the harddrive (I tried to do a backup/syncing of my complete home-folder with unison), it silently cannot be accessed at some random time. That means - I can neither read nor write to the drive, restarting the router is the only thing that works. By restarting I mean to unplug the eletricity-cable. When I reset the router with the reset-function, it won't connect to the internet again. When I restart the HDD (it has a power switch), it is still not accessible.

The drive stops working also when I copy a lot of files with nautilus. It works fine if I only copy some files.

I've mounted it as an Samba device, as this is was my router is a capable of. I also tried an FTP-drive, but the same thing occurs.

Is this an router security issue (a lot of files at the same time—I'll block that device!)?

Or an GNOME/gvfs/nautilus issue (I access the drive via /run/user/1000/gvfs/smb-share....)?

Or something else I didn't think about?

0

Chances are it's just bad luck! For this to be successful many things have to work:-

  1. The external disk has to be compatible with your router (and not take too much power). Try an USB memory stick instead (just to test).

  2. The router has to be happy with Ext3 - chances are it was tested with NTFS or FAT. Format your disk with one of those and test.

  3. It likes comunicating with Linux - again, it was probably tested with a Windows PC. If you have access to one, try sending files with one of those.

I tried a similar trick with my router although it didn't crash/freeze like yours. It would happily write any size of file to the disk, but when reading it would cap files to 4Gb. I put that down to buggy firmware (it was even running Samba on Linux).

If you need a local storage, get hold of a Raspberry Pi and make a home server with that.

1
  • 1. The external disk is rather old and comes with an own power supply. So I don't think that's the problem, but I'll try an memory stick. 2. The routers manual says ext3 is allowed. 3. Thanks I'll try. – kartoffelsalat Jun 25 '14 at 13:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.