This question already has an answer here:

I have ncurses apps (say, aptitude) working nice in plain xterm (or gnome-terminal, or any other terminal I've tried), but if I run it inside tmux session, screen isn't properly refreshed while I do some navigation through the menu.

Example screenshot: aptitude qinside tmux

(full resolution: http://i.imgur.com/jKLCX3A.png)

The same happens with other ncurses apps inside tmux: say, cgdb. And again, without tmux they work nice.

How to make it work correctly in tmux too?

(OS is Linux Mint 13, if that does matter)

marked as duplicate by jasonwryan, Caleb, Anthon, slm Jun 25 '14 at 11:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


From the tmux FAQ:

* PLEASE NOTE: most display problems are due to incorrect TERM! Before       *
* reporting problems make SURE that TERM settings are correct inside and     *
* outside tmux.                                                              *
*                                                                            *
* Inside tmux TERM must be "screen" or similar (such as "screen-256color").  *
* Don't bother reporting problems where it isn't!
  • Thanks, as I just found out after your answer, my tmux config was actually correct (setting TERM to screen-256color), but for some reason this setting is overrided by one in the ~/.zshrc, so TERM is finally set to xterm-256color. I'd be very glad if you take a look at my related question unix.stackexchange.com/questions/139082/… – Dmitry Frank Jun 25 '14 at 9:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.