0

I'm running an ARM version of Ubuntu provided by Linaro. I'm not 100% sure on current version as I'm re-installing using the manufacturing tools (I want to say its Linaro 11.10). However, I was wondering if anyone could help me with an issue?

I did a sudo apt-get remove gnome*, to get rid of all the GNOME packages since I do not want a GUI. I restarted the system and I did not get a CLI. The screen was just black.

Is there a way to get to CLI or where/how would I change the files to boot to CLI?

  • I would simply leave these things installed and switch the default runlevel to a non GUI one. – slm Jun 24 '14 at 13:00
  • The reason to not have it installed is to save limit the number of unnecessary packages in the memory. Either way I am still having issues of changing the runlevel and having it boot directly to CLI. – Keith Jun 24 '14 at 13:09
  • Removing them only saves on disk space, if you're running in a GUI-less runlevel then none of the GNOME packages would be loaded consuming any RAM. I'd take a look at this SU Q&A: superuser.com/questions/310978/starting-ubuntu-without-the-gui – slm Jun 24 '14 at 13:15
  • I have taken a look at a few guides. I am not sure of my bootloader but I do know I am running System V. So I believe this has different runlevel meanings. I have tried numerous times of changing them to boot directly to CLI and not run the GUI with no success. I will take a look at your link to further my knowledge tho. – Keith Jun 24 '14 at 13:20
  • What kind of console do you have, hardware-wise? Do you want to keep a GUI (an X server) available (to be reached upon explicit demand with startx), or do you want to remove X altogether? – Gilles Jun 24 '14 at 23:26
0

You can switch to another console by using Ctrl + Alt + F1/F2/F3/... to have access to a text-console. If that doesn't work, restart the system with single as kernel parameter.

As soon as you have a console, you can login to the system and stop your display manager: Check which display manager is running with ps aux|grep dm or look for gdm or other *dm in /etc/init.d/ and check if they are started with /etc/init.d/gdm status

stop the currently running display manager with:

/etc/init.d/gdm stop

Now, disable the display manager for the next boot:

sudo vi /etc/init/gdm.conf

change

stop on runlevel [016] 

to

stop on runlevel [0126]
  • I am running lightdm. I had to use 'service lightdm stop' to stop it from running. I changed the runlevel to as you said and upon reboot it seems to still boot into the GUI. Any other ideas? – Keith Jun 24 '14 at 13:15
  • 1
    You dit edit sudo vi /etc/init/lightdm.conf instead of sudo vi /etc/init/gdm.conf, right? Uninstalling lightdm would also work since you seem to want to remove gnome completely. – jensd Jun 25 '14 at 8:57
  • Yes I edited lightdm.conf, I want to say that I may not have the right graphics drivers for when the GUI is loaded. A screen black screen with a blinking cursor comes up if I change the runlevel to a 1. But if i just ad 2 to the stop on runlevel it still loads the GUI – Keith Jun 25 '14 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.