1

I've been looking on Google for 4 hours and I can't find a solution to my problem.

I have a computer running CentOS 5.10 using Kernel 2.6.18-371.9.1.el5 and I would like to upgrade my kernel to 2.6.32 in order to run lxc (it need at least kernel 2.6.29).

I've been following this HowTo and tried to install the 2.6.32 source package by typing:

[user@stag-devCentOS]$ rpm -i http://vault.centos.org/6.5/updates/Source/SPackages/kernel-2.6.32-431.20.3.el6.src.rpm 2>&1 | grep -v mock

I know it's the kernel for 6.5 version but I wasn't able to find a 2.6.32 kernel for CentOS 5.10.

When I'm running this command line, I get a md5 sum mismatch like this

[tanguy@stag-devCentos ~]$ rpm -i http://vault.centos.org/6.5/updates/Source/SPackages/kernel-2.6.32-431.20.3.el6.src.rpm 2>&1 | grep -v mock
warning: /var/tmp/rpm-xfer.ecr3WX: Header V3 RSA/SHA1 signature: NOKEY, key ID c105b9de
error: unpacking of archive failed on file /home/tanguy/rpmbuild/SOURCES/Makefile.common;53a94866: cpio: MD5 sum mismatch

I tried to add --nomd5 and rebuild but it doesn't help.

I've tried a manual upgrade of the kernel, everything gone well until boot. i'm getting this error:

switchroot: mout failed: No such file or directory
Kernel panic - not syncing Attempted to kill init!
Pid: 1, comm: init Not tainted 2.6.32.27 #1
Call Trace:
[<ffffffff81041d3a>] ? panic+0x86/0x13d
[<ffffffff810c644e>] ? pcpu_chunk_relocate+0x10/0x6b
[<ffffffff810cb3db>] ? deactivate_super+0x20/0x77
[<ffffffff8104a66c>] ? exit_ptrace+0x20/0xee
[<ffffffff810448ae>] ? do_exit+0x72/0x633
[<ffffffff81044edc>] ? do_group-exit+0x6d/0x97
[<ffffffff81044f18>] ? sys_exit_group+0x12/0x16
[<ffffffff8100b96b>] ? system_call_fastpath+0x16/0x1b

Do you have any idea ?

  • can you add the error/warning in english again? but please don't post a screenshot. – polym Jun 24 '14 at 11:32
3

Have you looked at ELRepo? They have kernels from the 3.2 branch for EL5 (and therefore CentOS5) which should run lxc. It might save you having to compile! Have a look here.

  • Didn't know ElRepo, thanks, i'll read more about it and update my post if i succed. – Tifa Jun 24 '14 at 12:30
  • Thanks sir, it worked flawless. I downloaded a 3.2.60-1.el5.elrepo kernel on Elrepo and installed it. – Tifa Jun 25 '14 at 6:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.