2

We have polycom phones for use with our Asterisk 1.8 PBX.

Consider this: On the phone at extension 2536, I dial 3333. This should originate a call from extension 2500 to play a sound. In other words, I want to use the phone at 2536 to play sounds over another phone. Now this I am able to do, but I have to answer the phone that receives the call. I want it to auto-answer via it's speakerphone. I've already configured the sip.cfg files in the polycom tftp directory.

Both phones are Polycom 601's.

[macro-RingAngelusBell]
include => intercom
exten => s,1, NoOp(Ringing-zee dee bell! ${CHANNEL} dialed: ${MACRO_EXTEN})
;same => n,ChanIsAvail(SIP/2500,js)
same => n,Originate(SIP/2500,exten,soundeffects,thebell,1)
same => n,NoOp(Originate Status: ${ORIGINATE_STATUS})
same => n,Hangup()

[soundeffects]
exten => thebell,1(thebell),SIPAddHeader(Alert-Info: Auto Answer)
same => n, Answer()
same => n,NoOp(soundeffects: thebell)
same => n,Playback(soundfx/angelusbell)
same => n,Hangup()

I've tried this, too: In this case, when I dial 3333 from 2536, 2500 rings, but it isn't supposed to. Instead, 2500 is supposed to CALL "thebell" from it's speakerphone and play the bell sound over it's speaker.

[macro-RingAngelusBell]
include => intercom
exten => s,1, NoOp(Ringing-zee dee bell! ${CHANNEL} dialed: ${MACRO_EXTEN})
same => n,SIPAddHeader(Alert-Info: Auto Answer)
same => n,Originate(SIP/2500,app,Dial(thebell))
same => n,NoOp(Originate Status: ${ORIGINATE_STATUS})
same => n,Hangup()

And in my sip.cfg:

<alertInfo voIpProt.SIP.alertInfo.1.value="Auto Answer"
VoIpProt.SIP.alertInfo.1.class="3"
voIpProt.SIP.alertInfo.2.value="intercom" voIpProt.SIP.alertInfo.2.class="4"
/>

alertInfo.1.value is set to "Auto Answer" because the phone should not ring at all, although I've tried Ring Answer and it doesn't make any difference.

I have to say that I'm rather confused... I know what I want but not how to get it! The call gets originated from the soundplay, but not using the intercom.

1

For polycom phones have be

Alert-Info: Ring Answer

Or have be in config

<voIpProt>
      <alertInfo voIpProt.SIP.alertInfo.1.value="Ring Answer"  voIpProt.SIP.alertInfo.1./>  

You also can change that option via phone's web interface

  • Thanks for your attention. In the dialplan, it doesn't matter if I send Ring Answer or Auto Answer - it always rings. I'm working with a Polycom 601 (which, by the way, I can't find the setting for ring type in it's web interface). – bgmCoder Jun 25 '14 at 16:33
  • The problem is that 2500 is supposed to call using intercom. – bgmCoder Jun 25 '14 at 16:42
  • Yes. Ring Answer = intercom on polycom phones. – arheops Jun 25 '14 at 18:25
  • Like I said in my comment, it still rings. Is there something wrong in my dialplan? – bgmCoder Jun 25 '14 at 18:33
  • YES. you use OTHER alert info. – arheops Jun 25 '14 at 18:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.