0

I am trying to configure Asterisk 12.3.2 on Debian 6.0.9 but I am getting an error:

"configure: error: *** termcap support no found (on modern systems, this typically means the ncurses development package is missing)".

When I try to install it by:

apt-get install libncurses5-dev

I get the message that package cannot be found.

  • 3
    What terminal emulator are you using? Have you tried looking through the available ncurses packages with apt-cache search ncurses? – arnefm Jun 23 '14 at 11:01
  • If you have issues with compilation, it is highly recommended NOT build asterisk but use rpm(pre-builded) version. – arheops Jun 23 '14 at 15:43
  • 1
    Asterisk is available for Debian, including a wheezy packport. Is there some reason you are trying to build it from source? – Faheem Mitha Jun 23 '14 at 22:03
3

libncurses-dev is what you want.

Additionally, you may be interested to know that you can install all the current prerequisites with contrib/scripts/install_prereq. You pass it the install argument like: contrib/scripts/install_prereq install to install all dependent packages on your system.

2

Acording to this blog post titled: How to install Asterisk 1.8.4 on Debian 6.0.1 I think you want to install ncurses-dev and not libncurses5-dev. They're building an older version of Asterisk but thought this might be of help in your situation.

Also you can see all the ncurse packages like so:

$ apt-cache search ncurses | grep dev
0

I had this same problem on Centos 7 while trying to install Asterisk 13.4.

I solved it by installing libtermcap-devel.

yum install libtermcap-devel

It will automatically resolve and install ncurses-devel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.