2

this is my situation: there are three computers

  1. lab server (CentOS)
  2. lab personal computer(window s7)
  3. personal laptop(ubuntu)

since the lab server only allowed ip address of my desktop at the lab, I was unable to establish a direct remote connection to the lab server through my laptop.

So I have reached to the point where I made my lap desktop into a ssh server where now I can eventually connect to the lab server through my laptop.

But the problem is that I was only able to connect to the lab server only in the CLI basis. The real deal is that I want to use the simulation programs which involves X windows stuff.

After a lot of struggling, with my laptop---lab desktop----lab server connected established, I execute the simulation program through my laptop but what really happens is the simulation program is executed and displayed at the 'lab desktop'..

in other words, I have failed to send the X windows display data from 'lab server' to 'my laptop'..

I guess this does make sense since eventually the regardless of how further I am logged in to the lab server, the connection coming 'out' from the lab server is tunneled to my 'lab desktop'. So I guess the X display data is automatically sent to my 'lab desktop'.

So I am guessing that there could be two ways to solve this:

  1. find a way that I don't know yet which will enable the X display data to be sent from the 'lab server' directly to 'my laptop'...
  2. find a way to somehow 'port forward' my lab desktop so that the incoming X display data from the lab server toward 'my laptop'...

Can anyone help me in anyway on this matter??

  • Can you please add more details on how you've set up your "lab personal computer" to act as an SSH server? What command(s) do you use to connect remotely? It may be that you're simply missing the right options/switches... – Joseph R. Jun 23 '14 at 10:30
  • my lab desktop is running on Windows 7 so I installed Cygwin + openSSH which I followed from a post I googled. When I want my lab desktop to act as ssh server all I do is go to Cygwin terminal and type 'cygrunsrv -S sshd'. The rest is all done from my laptop. – kwagjj Jun 23 '14 at 22:31
1

Try:

$ ssh lab_desktop -L 2200:lab_server:22 -vvv
$ ssh -Y <USERNAME>@localhost -p 2200
  • could you briefly explain what this means???? I'm not yet fluent with linux.. – kwagjj Jun 23 '14 at 22:32
  • so I should type this in from my 'laptop'?? – kwagjj Jun 24 '14 at 0:26
  • thanks I understood it in the end through questioning about this in other posts. – kwagjj Jun 25 '14 at 7:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.