0

I can VNC fine to my machine. But VNC is slow, and to try something else, I wanted to use gnome-session or gnome-panel over SSH via X. But it simply gives me a black bar across the whole screen.

No app shortcuts, however, I can right click and click preferences. But there's no functionality.

Using Debian 7 x64 on an Intel Atom system. Connecting from OS X 10.9, XQuartz.

  • Try using ssh -Y <YourMachine> instead of -X option – Tejas Jun 23 '14 at 9:28
0

I have the same issue and SSH with -X or -Y gives same result.

Here is the reason and "answer" in form of a workaround.

The reason is that the menu background aka "the black bar" is rendered on top of the gnome panel instead of behind it.

I have created this bug report at xquartz, and hopefully they will solve it.

https://xquartz.macosforge.org/trac/ticket/2093#ticket

There is a workaround.

After the session is loaded in xQuartz, its necessary to hit # alt a, then select under x11 menu and windows, bring all to front!

This will put the gnome menu back on top of the background, and problem is solved for that session.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.