2

I updated libc on my Debian (Jessie) and with it hundreds of packages. Now I can't sign in using a display manager. After entering password and signing in it loads with a black screen and then pushes me back to the display manager.

  • Logging in via a virtual terminal and startx with my desktop environments (xfce, xmonad) still works.

  • I installed another display manager (gdm, lightdm, xdm) and tried to log in with different users (including users with empty sessions) and I even replaced systemd with init, but that didn't help. And I installed a fresh xorg.

  • I installed not just libc, but the development files libc-dev-bin in this one step. So there are even more new packages.

  • My system is multiarch. Got i386 and amd64 packages installed.

  • I have one screen and use the Nvidia card and proprietary drivers via bumblebee. Usually everything runs on the Intel graphics card.

  • Years ago, the system was an Aptosid. But I changed all repository sources to Debian. After many updates, all packages should be from a Debian repo by now, I guess.

  • I don't know if its a bug, but I can't start a terminal emulator on X, which has been started with startx. I have this issue since some years but it wasn't a problem. Running a terminal as root still works on any X.

  • It has installed some libwayland-* packages, but i don't have weston installed.

  • I updated some libpam and libdbus packages now. No difference.

  • I checked the auth logs and other logs, but i couldn't find anything useful. Suggestions where I should search next?

  • apt log of the update.

Edit:

  • The display disables and enables while black screen. Maybe an attempt to change screen resolution.

  • In ~/.xsession-errors there is OpenSSL version mismatch. Built against 1000105f, you have 10001090. Maybe it's the issue, but I don't know how to fix this.

  • Did you check Xorg log (/var/log/Xorg.0.log or similar) for the reason of session crashing? – zagrimsan Jun 23 '14 at 3:07
  • @zagrimsan There is no marked error in the Xorg log. But its suspicious that there is no note for a successful terminated Xorg, like in the other logs. – Vektorweg Jun 23 '14 at 5:26
  • libc is a major component of the system. Have you rebooted since the upgrade? Weird things can happen when you change the foundation of the system. – lornix Jun 23 '14 at 5:30
  • @lornix I rebooted for every try. So roughly twenty times. – Vektorweg Jun 23 '14 at 5:35
  • You might try reinstalling the video driver. I had an issue where the simplistic display manager login screen worked, but the accelerated video graphics (NVidia) did not, producing the same kind of login->black->back to login type of response. It can be done through a console (Ctrl-Alt-F1) if need be. – lornix Jun 23 '14 at 5:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.