I burned a live session of Linux Mint 17 Cinnamon to a USB stick. Then I installed LM17C into an external hard drive by using this USB stick. I managed to do it and even successfully started on my computer.

However I have tried to boot it on another computer, yet it did not started and gave the error below:

error: file '/boot/grub/i386-pc/normal.mod' not found.
entering rescue mode...
grub rescue >

My computer has an Intel processor, but the second PC has AMD. I think this is the problem. I do not know how to solve it, though.

marked as duplicate by slm, cuonglm, vonbrand, jasonwryan, goldilocks Jun 19 '14 at 17:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


Apologize in advance, this isn't super helpful, but I think I can confirm that your issue may be the processor. I was recently trying to install CentOS on a laptop and encountered an incompatibility issue with Haswell, so it was sort of the inverse of your issue. Try yet another computer, with the same type of processor as your initial computer on which the installation worked.

  • Yes, I also think that is the best solution. Nevertheless it would be great if there was a Linux Mint ISO with AMD support, I could not found it. Thanks again. :) – Eray Erdin Jun 19 '14 at 17:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.